Deleting User permissions in BItbucket Server via the REST api.

Hi I'm trying to remove user permissions via the bitbucket server (4.10.1) api.

I can use GET to access an individual users info. But when I try DELETE or PUT to change the permissions for individual users I get a paginated list of all users and the permissions are not changed.


Here is the delete address:

https://<URL>/rest/api/1.0/admin/permissions/users?name=<username>

The status is 200 not 204.

 

Just incase, I also tried it like this with the same results:

https://<URL>/rest/api/1.0/admin/permissions/users?<username>

 

I've tried this both with python3 and postman. For example in python3:  

r = requests.delete(url+"admin/permissions/users?name=<username>", verify=ca,cert=certtup)

It seems pretty strange that this is returing a list of all users. Has anyone experienced this? 

1 answer

We resolved this on our end. Thanks anyway.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,745 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you