Create a bitbucket cloud repository gives error 500 Internal Server Error

Hi,

 

I have successfully created projects, queried repositories, but when I try to create a repository   https://api.bitbucket.org/2.0/repositories/assecofactory/abc1 with the following content

{
"scm": "git",
"is_private": "true", 
"fork_policy": "no_public_forks", 
"project": {
"key": "A1481624854252"
}

Using POST and basicauth, I get an error 500 back, and the following response

{

"type": "error",
"error": {
"message": "'NoneType' object has no attribute 'copy'",
"id": "243c658028c54816bf0521a154cd4cd0"
}
}

I have tried to variation of the request content, but get the same response back.

 

Any ideas?

1 answer

1 accepted

It turned out to by Postman application, after restarting everything worked as intended

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

631 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot