Connecting Stash to SQL Azure

Hi

Using a clean installation of Stash I am attempting to connect to a SQL Azure database. After specifying 'Microsoft SQL Server' as database type and all the required fields I am receiving this error:

"Stash does not have adequate permissions to modify the target database when connected as the specified user. Please check that the user has permission to CREATE and DROP tables and to INSERT and DELETE data. For information about creating a database for use with Stash, please refer to the Stash documentation."

I've tried to comply to all prerequisites described in https://confluence.atlassian.com/display/STASH031/Connecting+Stash+to+SQL+Serverand tried to connect to the database using 2 different kind of users (database owner and user created using the script in documentation). Using Microsoft SQL Server Management Studio I am able to CREATE, DROP tables and INSERT and DELETE data with both users.

Currently I am kinda clueless what else I could try. Does anyone have an idea how to fix this issue or how to get a more specific error message?

Thanks

2 answers

1 accepted

0 vote
Peter Koczan Atlassian Team Jul 27, 2014

Hi Mark,

As for reference I will also put the improvement request for this: https://jira.atlassian.com/browse/STASH-5054

Kind regards,

Peter

Did you ever resolve this? I realise it was a long time ago!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

21,857 views 26 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you