Can not push to old repos after upgrade from Bitbucket 4.12 to 5.3.1 Edited

I upgraded from Bitbucket 4.12 to 5.3.1.

 

When I create a new repo I can pull and push to it with no issue. I have tried pushing to master as well as branches and all works great.

 

The issue is when I try to push to my repos that were created in 4.12. I can pull from them with no issue, but when I push to them I get a an error "refs/heads/develop, pre-receive hook declined". From what I can tell, this has something to do with permissions and the hooks. However, looking at the repos I can not tell what is different between the old ones and new ones that would cause this issue.

Any guidance would be greatly appreciated.

 

Update: After more testing, this seems like it is only on some of the old repositories. Others seem to be working fine.

1 answer

1 accepted

Finally figured it out. The /hooks/post-receive.d/20_bitbucket_callback was not executable. 

To fix this, in the hooks folder run the following command:

sudo chmod 750 -R *

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

23,818 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you