Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,817
Community Members
 
Community Events
168
Community Groups

Build failing when updating to Drupal 8.9.19

CI build is failing with the updated to Drupal 8.9.19. No idea what the error means. This is just one example of what looks likes dozens of errors that could not install.

Project in running Drupal 8.9, Composer 2, PHP 7.3

 

Failed to extract consolidation/self-update: (9) '/usr/bin/unzip' -qq '/opt/atlassian/pipelines/agent/build/vendor/composer/tmp-2deb2f71c02531c0c4c325d645f52a4d' -d '/opt/atlassian/pipelines/agent/build/vendor/composer/98406dfb'
unzip: cannot find or open /opt/atlassian/pipelines/agent/build/vendor/composer/tmp-2deb2f71c02531c0c4c325d645f52a4d.
This most likely is due to a custom installer plugin not handling the returned Promise from the downloader
Install of consolidation/self-update failed
Failed to extract dflydev/placeholder-resolver: (9) '/usr/bin/unzip' -qq '/opt/atlassian/pipelines/agent/build/vendor/composer/tmp-2d79b64ea94727df655cd0657e187989' -d '/opt/atlassian/pipelines/agent/build/vendor/composer/66acf24a'
unzip: cannot find or open /opt/atlassian/pipelines/agent/build/vendor/composer/tmp-2d79b64ea94727df655cd0657e187989.


1 answer

1 accepted

0 votes
Answer accepted

Never mind, fixed!

I'm interested to know how you fixed it, since I have roughly the same error message. Did you downgrade to Composer v1? Thanks!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events