Bitbucket webhook doesnt contain Content-Type: application/json in its header Edited

Hi,

I tried to configure Bitbucket 5.5 repository web-hook so that it could post event to 3rd party notification service. (DingTalk).

I tried with test connection button but the service always report that the post action should have a header with "Content-Type: application/json". 

I checked the data from bitbucket, it seems that the data posted does not have this value field in its header. 

How to configure the webhook or modify bitbucket files to workaround this issue?

thanks.

0 answers

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

1,754 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you