Bitbucket service fails to start after install, bundled JRE not loaded

Hello I installed Bitbucket server 4.10.1 on CentOS 6 in console mode. Bitbucket also installed the bundlet JRE.

However when I

service atlbitbucket start

I get

Atlassian Bitbucket does not support Java 1.6.0_31.
 Please start the product with Java 8 or greater.

How can I tell Bitbucket to use the bundled JRE?

--------

Edit: solution

Vishnus question pointed us to the answer:

in

/home/atlbitbucket/.bash_profile

add

JAVA_HOME=/opt/atlassian/bitbucket/4.10.1/jre
PATH=$JAVA_HOME:$PATH:$HOME/bin

Thanks, Vishnu!

1 answer

1 accepted

2 votes
Answer accepted

HI Gokhan,

 

  Can you please check the JAVA home in the bashrc profile of the user who is starting the process.It would have been hard coded in his profile which will be overrriden while starting the process

 

Thanks

Vishnu

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 14, 2019 in Bitbucket Pipelines

Building a Bitbucket Pipe as a casual coder

...ipe.sh :  #!/bin/bash source "$(dirname "$0")/common.sh" enable_debug extra_args="" if [[ "${DEBUG}" == "true" ]]; then extra_args="--verbose" fi # mandatory variables R...

247 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you