Bitbucket Server on SuSE SLES 12 SP1. Service starts but connection timeout on HTML connection Edited

Hi, 

I am installing Jira 7.4.1 and Bitbucket 5.2.2 on a server on SLES 12 SP1. I used the .bin file for Jira and it works without any major problems.

I had several problems using the .bin for Bitbucket so I resorted to the manual install file (tar.gz). I have followed the steps  written here.

Prerequisites are OK (Git and perl-Error)

I have then followed the guide on how to setup Bitbucket as a service and it works perfectly (after a few more environment variables problems in script set-jre-home.sh. - command line was OK but when started as a service it lost track of the JRE_HOME). 

Here is what the service looks like

2017-08-01 17_16_33-172.18.135.23 - PuTTY.png

 

When I try to reach the application on port 7990 I get a ERR_CONNECTION_TIMED_OUT

netstat -pln show port 7990 is listening

Here is the content of the atlassian-bitbucket.log

 

I have been looking all over the site for answers and I have tried to find other log files that would give me any clue as to what is going on but I can't find anything else. 

The install troubleshooting page hasn't been of much use either.

Any help in understanding the problem would be great. 

 

Thank you 

1 answer

This widget could not be displayed.
Jeff Thomas Atlassian Team Aug 01, 2017

Hi @Marc-Antoine LECLERCQ,

Since netstat shows that something is listening on port 7990 and the logs don't show any errors, can you verify that the firewall allows connections on port 7990?

Also, what is the result of running "curl http://localhost:7990" when on the server?

Hi, 

 

Here is the result of curl on localhost on the machine : nothing

 

2017-08-01 19_04_16-Utilisation de configure, make, make install - Linux Attitude.png

When I run it on another machine using the external IP, I get Connection refused.

Here is a screenshot of the iptables -L 2017-08-01 19_05_11-172.18.135.23 - PuTTY.png

 

Thank you for your help. 

EDIT: 

Alright I believe I  might have a clue as to what is happening. 

 

I am reaching my server through a NAT address. This made JIRA's dashboard slow to load (I changed the base url to the real IP and it fixed the problem). 

 

This might be why I can't get bitbucket server to display. 

 

I'll try and investigate this further. 

Update : 

curl now displays HTML when trying locally on the server

  • curl http://localhost:7990/setup 
  • curl http://<non NAT IP>/setup 

I had a 302 error in the atlassian-bitbucket-access.log when I tried without the /setup. It seems that the webserver is unable to do the temporary redirect. 

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 10, 2018 in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

243 views 14 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you