Bitbucket Server not starting

I changed the keystore file of the Tomcat, and had a couple of errors afterwards. After I fixed them (https://confluence.atlassian.com/bitbucketserverkb/bitbucket-server-does-not-start-could-not-acquire-change-log-lock-779171307.html) I tried starting it again. Now it does not print any error in the log files, but keeps hanging on "Initializing Spring context". What should I do next?


Bitbucket Version 4.6.0

3 answers

This widget could not be displayed.
Jeff Thomas Atlassian Team Oct 25, 2016

Do you see anything in the following two log files to indicate why it's not starting?

$BITBUCKET_HOME/log/atlassian-bitbucket.log
<Bitbucket Server installation directory>/logs/catalina.out

This widget could not be displayed.

Just made a fresh restart.

atlassian-bitbucket.log:

... (Older timestamps)

2016-10-25 18:35:05,486 INFO [spring-startup] c.a.s.i.server.BuildInfoLogger Starting Bitbucket 4.6.0 (e31c644 built on Mon May 09 06:21:50 CEST 2016)
2016-10-25 18:35:05,486 INFO [spring-startup] c.a.s.i.server.BuildInfoLogger JVM: Oracle Corporation Java HotSpot(TM) 64-Bit Server VM 1.8.0_74-b02
2016-10-25 18:35:05,502 INFO [spring-startup] c.a.s.internal.home.HomeLockAcquirer Successfully acquired lock on home directory C:\Atlassian\ApplicationData\Bitbucket
2016-10-25 18:35:07,814 WARN [spring-startup] c.z.hikari.util.DriverDataSource Registered driver with driverClassName=oracle.jdbc.driver.OracleDriver was not found, trying direct instantiation.

 

catalina.2016-10-25.log:

... (Older timestamps)

25-Oct-2016 18:34:49.285 WARNING [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'maxSpareThreads' to '75' did not find a matching property.
25-Oct-2016 18:34:49.332 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlValidation' to 'false' did not find a matching property.
25-Oct-2016 18:34:49.332 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlNamespaceAware' to 'false' did not find a matching property.
25-Oct-2016 18:34:49.363 INFO [main] org.apache.catalina.core.AprLifecycleListener.lifecycleEvent The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Atlassian\Bitbucket\4.6.0\lib\native;C:\\Atlassian\\ApplicationData\\Bitbucket\lib\native
25-Oct-2016 18:34:49.628 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-80"]
25-Oct-2016 18:34:49.722 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read
25-Oct-2016 18:34:49.738 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-443"]
25-Oct-2016 18:34:50.175 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read
25-Oct-2016 18:34:50.175 INFO [main] org.apache.catalina.startup.Catalina.load Initialization processed in 1530 ms
25-Oct-2016 18:34:50.207 INFO [main] org.apache.catalina.core.StandardService.startInternal Starting service Catalina
25-Oct-2016 18:34:50.207 INFO [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet Engine: Apache Tomcat/8.0.32
25-Oct-2016 18:34:58.050 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
25-Oct-2016 18:34:59.768 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-80"]
25-Oct-2016 18:34:59.909 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-443"]
25-Oct-2016 18:34:59.909 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 9737 ms

This widget could not be displayed.

HI Phillipp,

  Can you please try to clear the plugin cache and try restarting again.I think on of you core plugins frame work are corropt.

  1. Shut Bitbucket Server down.
  2. Backup and remove the following directories. The core plugins will be rebuilt when Bitbucket Server starts again.
    1. $BITBUCKET_HOME/plugins/.bundled-plugins/
    2. $BITBUCKET_HOME/plugins/.osgi-cache/
  3. Restart Bitbucket Server.

Thanks & Regards

Vishnu

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 10, 2018 in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

271 views 14 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you