Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket AD connection synchronisation is always failling Edited

Everytime we try to synchronize the Microsoft Active Directory we got a failed error.

 

We tried more then once, even rebooting the server is not helping with the synchronisation.

It was working fine before we tried to had nested groups for giving rights to differents users. We also tried to change the user account password for AD connection. It is still not working.

I wonder if my other question is related to this one as i got a problem with Groups?

Alain

 

This is the error i find under the time i tried the last synchro:

2021-05-27 14:08:23,441 ERROR [CrowdUsnChangedCacheRefresher:thread-1] c.a.c.d.l.m.e.ActiveDirectoryUserAttributesMapper The following record does not have a username:
NameAwareAttribute; attributes: {objectguid=NameAwareAttribute; id: objectGUID; hasValuesAsNames: false; orderMatters: false; values: [[B@7ae82cf0], displayname=NameAwareAttribute;
id: displayName; hasValuesAsNames: false; orderMatters: false; values: [adm-PCalafren], objectsid=NameAwareAttribute; id: objectSid; hasValuesAsNames: false; orderMatters: false; values:
[[B@6a8ca5b8], useraccountcontrol=NameAwareAttribute; id: userAccountControl; hasValuesAsNames: false; orderMatters: false; values: [66048], primarygroupid=NameAwareAttribute; id:
primaryGroupID; hasValuesAsNames: false; orderMatters: false; values: [513], usnchanged=NameAwareAttribute; id: uSNChanged; hasValuesAsNames: false; orderMatters: false; values: [139164079]}

2021-05-27 14:08:23,449 ERROR [Caesium-1-3] c.a.c.d.DbCachingDirectoryPoller Error occurred while refreshing the cache for directory [ 294913 ].

com.atlassian.crowd.exception.OperationFailedException: java.util.concurrent.ExecutionException: com.atlassian.crowd.exception.OperationFailedException: org.springframework.ldap.UncategorizedLdapException:
Unable to find the username of the principal.

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

530 views 4 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you