Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Authentication is failing from AWS instance to Bitbucket git repo, not an SSH key issue

Vlad Kolev July 11, 2023

Trying to access a git repo like this one below from a Linux instance at AWS

https://my_user@bitbucket.org/my_space/my_git_repo.git

Getting 'Invalid credentials'.

I tried different users, all with valid credentials, to no avail.

It worked fine before, but I didn't try it for quite some time. No changes from my end since.

Apparently, not the SSH key rotation issue.

Any advice is highly appreciated!

 

2 answers

1 accepted

0 votes
Answer accepted
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 12, 2023

Hi @Vlad Kolev and welcome to the community!

Are you perhaps using the account's password? We have deprecated the use of account passwords for Git over HTTPS and API. An account's password can be used only for logging in to https://bitbucket.org/ from browser.

You will need to generate an app password and use that instead:

An app password can be used along with the user's username. So, the my_user part in the URL needs to be the username listed here https://bitbucket.org/account/settings/ for the account you generate the app password.

Please feel free to let me know how it goes and if you have any questions!

Kind regards,
Theodora

Vlad Kolev July 12, 2023

Thanks Theodora,

This solved the problem!

Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 14, 2023

That's good to hear Vlad and you are very welcome!

Please feel free to reach out if you ever need anything else!

Vlad Kolev August 5, 2023

Hello,

I'm having an issue accessing another repo at the same Bitbucket account and trying to access it from the same AWS instance as the first repo. I was getting challenged for password when doing git pull. I triedrtried enter the same Application Password I use for the first repo, but it didn't work. Then I created a new Application Password for the second repo, but it didn't work either. I did all that multiple times, so issues with typos and such may be resonably rulled out. The first repo still works just fine...

Please advise.

Thank you so much!

0 votes
Vlad Kolev August 6, 2023

Okay, I've figured the issue with the second repository. The repo access URL was specifying a user which didn't create the Application Password I was using. Once I changed the access URL accordingly, the same Application password which works for the first repo started working for the second repo as well. Problem solved! :)

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events