Any idea why start-stash.bat would be launching Crowd?

Hello.

I'm evaluating a whole bunch of Atlassian products and I've started with Crowd and Stash. I had both of these running and integrated and all was well. But then I needed to restart the server.

I ran Crowd first and was then getting the 'URL already in use' error. So I stopped Crowd and tried to run Stash on its own to see what happens. When I run the Stash start-stash.bat file, it actually runs Crowd!

This is the directory structure I'm using:

C:\Atlassian\Crowd\Install
C:\Atlassian\Crowd\Home
C:\Atlassian\Stash\Install
C:\Atlassian\Stash\Home

When I run start-stash.bat (from the Stash\Install\bin directory), it shows the following values in the command prompt:

Using CATALINA_BASE: "C:\Atlassian\Crowd\Install\apache-tomcat"
Using CATALINA_HOME: "C:\Atlassian\Crowd\Install\apache-tomcat"
Using CATALINA_TMPDIR: "C:\Atlassian\Crowd\Install\apache-tomcat\temp"
Using JRE_HOME: "C:\Progra~1\Java\jdk1.7.0_45"
Using CLASSPATH: "(Crowd)\bootstrap.jar;(Crowd)\tomcat-juli.jar"

Naturally, this means that it actually launches Crowd.

Any ideas? I had a look at environment variables but can't see anything wrong. My STASH_HOME variable has been set to "C:\Atlassian\Stash\Home". Also, this was working fine until I restarted.. don't know if that helps.

Any and all help hugely appreciated.

UPDATE

It turns out that this happens when I launch Crowd from a console and then run Stash from the same console. Crowd seems to set some environment variables that Stash then ends up using?

Seems that the solution is to run each one from separate consoles (i.e. close the first one and open a new one). Seems a bit silly, but there you have it.

P.S.

Because I have no karma points yet, I can't actually answer my own question, which leaves it open forever and a little less useful to the skim readers. If anyone would like to earn some karma points, by all means copy/paste my update above and I'll mark it as the answer!

1 answer

0 vote

Can you check if both apps are using the same port or not? Also, check setenv.bat file under bin folder to check if there is any wrong settings in there.

Hi Jobin.

The apps are (or certainly were) using different ports (8095 and 7990) - I've not changed these, as far as I'm aware - I'm not sure how you do that.

I've checked setenv.bat and there's nothing untoward in there (I've not changed anything). The line that sets STASH_HOME is still remmed out (so it's using the environment variable). It does also refer to CATALINA_HOME, but I don't know what this would be at run-time.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

2,044 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you