A just installed stash doesn't work

Dear sirs,

I just installed a stash instance on a linux machine, on a brand new microsoft Virtual Machine, on which is running and working an evaluation version of Jira.

I followed all steps described in https://confluence.atlassian.com/display/STASH/Installing+Stash+on+Linux+and+Mac, with an user created as in https://confluence.atlassian.com/display/STASH/Supported+platforms (by the way, I am not sure about notes ??Deploying multiple Atlassian applications in a single Tomcat container is not supported.?? and ??Stash does not currently support virtualised environments.??).

After step 7 of described procedure, web server reply with

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.IllegalStateException: No WebApplicationContext found: no ContextLoaderListener registered?

org.springframework.web.filter.DelegatingFilterProxy.doFilter(DelegatingFilterProxy.java:251)

com.atlassian.plugin.servlet.filter.ServletFilterModuleContainerFilter.doFilter(ServletFilterModuleContainerFilter.java:71)

com.atlassian.plugin.servlet.filter.ServletFilterModuleContainerFilter.doFilter(ServletFilterModuleContainerFilter.java:63)

com.atlassian.plugin.servlet.filter.ServletFilterModuleContainerFilter.doFilter(ServletFilterModuleContainerFilter.java:71)

com.atlassian.plugin.servlet.filter.ServletFilterModuleContainerFilter.doFilter(ServletFilterModuleContainerFilter.java:63)

com.atlassian.johnson.spring.web.filter.BypassableDelegatingFilterProxy.doFilter(BypassableDelegatingFilterProxy.java:49)

com.atlassian.johnson.filters.AbstractJohnsonFilter.doFilter(AbstractJohnsonFilter.java:67)

com.atlassian.johnson.spring.web.filter.BypassableDelegatingFilterProxy.doFilter(BypassableDelegatingFilterProxy.java:49)

org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:88)

org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.32 logs.

I tried solutions described in https://confluence.atlassian.com/display/STASHKB/The+Spring+WebApplicationContext+could+not+be+started, but that does not work.

Have you any suggestion?

3 answers

1 accepted

Hi Nicola,

The above exception does not show the actual cause. Please create a support request under https://support.atlassian.com, with your full logs attached, and hopefully we can help you work out what's wrong.

Cheers,

Charles

Hi Charles,

thank you for redirection.

Hi all,

i have the same problem. I tried to start the stash service with following jdks: oracle jdk 1.7 and open jdk 1.6 (with an attribute JVM_SUPPORT_RECOMMENDED_ARGS="-Dstash.allow.openjdk=true" in the setenv.sh file). (i use GIT Version 1.8; Ubuntu 12.04.1 LTS; STASH Version 1.3.1). Do you have some solutions?

best regards

Michael

Hi Michael,

I'm afraid we need more information than that. When you try to login to stash do you see an error message about not supporting OpenJDK? If you're still seeing that after adding that openjdk flag then you haven't added the system property to the right place. If there error message is different, or in any case, you probably want to raise a support ticket with your logs attached so we can help you further. Unfortunately "No WebApplicationContext found" can mask all manner of sins, and we can't really tell what the underlying problem is just from that.

Cheers,

Charles

PS. As an aside we don't officially support OpenJDK. While that flag will bypass our check, we can't guarantee that everything will work as expected. Now, obviously. OpenJDK isn't all that different than Oracle JDK but we _do_ occassionally find minor (and subtle) differences; if you're running on production I would highly recommend downloading the Oracle JDK just-in-case.

ok thanks,

i installed the Oracle JDK again and after that, the application stash works fine. But after the installation of oracle JDK, the page of confluence is defect: http://s1.directupload.net/file/d/3098/v8nz42mb_jpg.htm . Confluence works only with Open JDK. Do I still make any settings in confluence?

best regards

Michael

Hi Michael,

I'm afraid I don't quite know what you mean. Confluence should work just as well with Oracle JDK, and in fact doesn't officially support OpenJDK either. The screenshot that you have attached looks a little strange; have you tried clearing your browser cache? Do you have any plugins installed that might be affecting the look of Confluence? If you think upgrading Java is the problem, you can still manually use OpenJDK by setting the JAVA_HOME environment variable just for Confluence, although I don't really see how that would fix your issue.

Let me know if that helps or not.

Charles

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

2,047 views 1 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you