500 when reaching the Pull Request Page

Hi.

 

When trying to reach the pull request settings page I get the following error:

 

In template widget.aui.form.checkbox: In 'print' tag, expression "$labelContent" evaluates to undefined.
com.google.template.soy.tofu.SoyTofuException: In template widget.aui.form.checkbox: In 'print' tag, expression "$labelContent" evaluates to undefined.

 

In template widget.aui.form.checkbox: In 'print' tag, expression "$labelContent" evaluates to undefined.

6 answers

This widget could not be displayed.

Hi.

 

I solved by disabling some of the plugins we were using and were causing this issue.

I will try later today to post here what was being used and that cause this issue.

Hi António -- Thanks a lot for confirming the proposed solution worked ;-) Have a nice day!

This widget could not be displayed.

Hi António,

It could be that some plugin is causing that.

Can you have a look at the atlassian-stash.log and post the full stack trace so we can see what is going on?

Thanks.

Best regards,
Thiago Bomfim
Atlassian Support

This widget could not be displayed.

Ah, found it. Incompatible plugin as you suggested. Disabling the plugin fixed it. Thanks for the speedy response!

Thanks for confirming it, Ben! It's good to know your issue has been fixed!

This widget could not be displayed.

Hi, this is what I get

 

2014-11-19 10:44:29,546 ERROR [http-bio-7990-exec-4] stash_admin @1PCXP5Hx644x510231x0 1 i.w.HandlerExceptionResolverImpl In template widget.aui.form.checkbox: In 'print' tag, e
com.google.template.soy.tofu.SoyTofuException: In template widget.aui.form.checkbox: In
at com.google.template.soy.tofu.internal.BaseTofu.renderMainHelper(BaseTofu.java
at com.google.template.soy.tofu.internal.BaseTofu.renderMain(BaseTofu.java:300)
at com.google.template.soy.tofu.internal.BaseTofu.access$100(BaseTofu.java:56) ~
at com.google.template.soy.tofu.internal.BaseTofu$RendererImpl.render(BaseTofu.j
at com.atlassian.soy.impl.DefaultSoyManager.render(DefaultSoyManager.java:118) ~
at com.atlassian.soy.impl.DefaultSoyTemplateRenderer.render(DefaultSoyTemplateRe
at com.atlassian.soy.impl.DefaultSoyTemplateRenderer.render(DefaultSoyTemplateRe
at com.atlassian.stash.unapprove.AutoUnapproveFormFragment.renderView(AutoUnappr
at com.atlassian.stash.unapprove.AutoUnapproveFormFragment.doView(AutoUnapproveF
at com.atlassian.stash.internal.plugin.PluginFormFragmentsFactoryImpl$PluginForm a]
at com.atlassian.stash.internal.web.admin.RepositoryAdminController.getPullReque
at com.atlassian.applinks.core.rest.context.ContextFilter.doFilter(ContextFilter
at com.atlassian.stash.internal.spring.security.StashAuthenticationFilter.doFilt
at com.atlassian.stash.internal.web.auth.BeforeLoginPluginAuthenticationFilter.d enticationFilter.class:na]
at com.atlassian.stash.internal.web.auth.BeforeLoginPluginAuthenticationFilter.d ss:na]
at com.atlassian.security.auth.trustedapps.filter.TrustedApplicationsFilter.doFi
at com.atlassian.oauth.serviceprovider.internal.servlet.OAuthFilter.doFilter(OAu
at com.hazelcast.web.WebFilter$RequestWrapper$1.forward(WebFilter.java:525) ~[ha
at com.atlassian.security.auth.trustedapps.filter.TrustedApplicationsFilter.doFi
at com.atlassian.oauth.serviceprovider.internal.servlet.OAuthFilter.doFilter(OAu
at com.atlassian.analytics.client.filter.DefaultAnalyticsFilter.doFilter(Default
at com.atlassian.core.filters.AbstractHttpFilter.doFilter(AbstractHttpFilter.jav
at com.atlassian.stash.internal.web.auth.BeforeLoginPluginAuthenticationFilter.d ticationFilter.class:na]
at com.atlassian.stash.internal.web.auth.BeforeLoginPluginAuthenticationFilter.d ss:na]
at com.atlassian.stash.internal.request.DefaultRequestManager.doAsRequest(Defaul
at com.hazelcast.web.WebFilter.doFilter(WebFilter.java:446) ~[hazelcast-wm-3.3-R
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:114
at java.lang.Thread.run(Thread.java:724) ~[na:1.7.0_25]

This widget could not be displayed.

I too get this message: In 'print' tag, expression "$labelContent" evaluates to undefined. when visiting the Pull Requests page under settings. This is post upgrade to 3.5.1. Has this issue been resolved yet?

This widget could not be displayed.

Has anyone been able to resolve this issue? We have exactly the same issue.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 10, 2018 in Bitbucket

What is your #1 piece of advice to new users getting started using Bitbucket?

Hello Community! My name is Claire Maynard, and I’m a Product Marketing Manager on the Bitbucket team. I’m interested in hearing what advice or tips you have for new users getting started on ...

241 views 14 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you