Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

2GB > Repository not letting me push

Hello!

We are a team of web developers and our business app code is hosted on Bitbucket. We just now realized we can't push our changes anymore due to our repository going over 2GB size. So, therefore, I went in and deleted a bunch of unneeded files and also older branches. I removed more than 1GB of files, but it still doesn't let me push and says I have a 2GB repository.

I've tried your guide: https://confluence.atlassian.com/bitbucket/reduce-repository-size-321848262.html and also searched online for some solutions, but it seems that we can't do anything from our side.

I've also opened a support ticket various hours ago but no one replied to us.
We're with Premium members and actually, this kind of lock can be very problematic to our running business if it will last any longer. It seems that the only solution is for you to run a 'git gc'.

Can someone please help? Also, could anyone tell us how to unlock this issue by ourselves, in the future maybe? Thanks a lot!

1 answer

1 accepted

0 votes
Answer accepted

Hi guys, 

 

I'm a fellow colleague of Stefano. 

Unfortunately, the situation is not resolved ad we still need the run of git gc command from Bitbucket support. 

 

It's very important for us, because this issue is blocking our business, we're depending on hot fixes for our customer and this is a big issue for us. 

 

We've opened a ticket 15 hours ago and still no response, we've also tried to contact you via phone but without success. 

 

A fast response will be very appreciated. 

 

Thanks. 

Hi Daniil,

thanks for the support.

 

Best, Matteo.

@Daniil Penkin 

please could you help us to run again the GC?

 

Thanks, Matteo.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

523 views 4 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you