Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
Highlighted

Help configuring bitbucket.properties

I'm having issues configuring the bitbucket.properties file.  After performing a database migration from the evaluation DB to our MSSQL server, no shared\bitbucket.properties file nor a shared directory were created.

I attempted to create the file and shared folder myself, changing the owner to the atlbitbucket user account.  The problem is after restarting the bitbucket service, this file is not being used.  None of the configuration properties I enter are loaded.

I'm just trying to get bitbucket working over SSL, but cannot get the changes entered into the Atlassian\Bitbucket\5.7.0\shared\bitbucket.properties file to load.  Is there something I'm missing?

3 comments

You say no "shared" directories were created.  As this is a migration, I would not expect them to be created, but either moved or copied from the originals.  Could you explain what you "migrated"?

Atlassian\Bitbucket\5.7.0\bin\set-bitbucket-home.sh

Seems the home directory is actually Atlassian\ApplicationData\Bitbucket

I am having a similar issue with configuring SSL via the bitbucket.properties file.

I created bitbucket.properties file in shared/, however Bitbucket does not appear to be reading the file. Even with the below properties, bitbucket is still accessible via port 7990 after restarting the server

I am running the bitbucket server 5.9.1 on Windows 10. 

bitbucket.properties contents


server.context-path=/bitbucket
server.port=7443 # Jira is using 8443
server.secure=true
server.scheme=https
server.ssl.enabled=true
server.ssl.client-auth=want
server.ssl.protocol=TLSv1.2
server.ssl.key-store="path to my keystore"
server.ssl.key-store-password="mypass"
server.ssl.key-password="mypass"
server.require-ssl=true

 

Fixed! I accidentally created the bitbucket.properties as a text file and the .txt extension was invisible. 

After removing the .txt extension, it worked fine

Comment

Log in or Sign up to comment
TAGS
Community showcase
Published in Bitbucket

Powering DevOps with Bitbucket Server & Data Center

Hi everyone, The Cloud team recently announced 12 new DevOps features that help developers ship better code, faster   ! While we’re all excited about the new improvements to Bitbucket ...

2,133 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you