Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

2gb, can't push and can't resolve by myself


We are a team of web developers and our business app code is hosted on Bitbucket. We just now realized we can't push our changes anymore due to our repository going over 2GB size. So, therefore, I went in and deleted a bunch of unneeded files and also older branches. I removed more than 1GB of files, but it still doesn't let me push and says I have a 2GB repository.

I've tried your guide: and also searched online for some solutions, but it seems that we can't do anything from our side.

I've also opened a support ticket one day ago but no one replied to us.
We're with Premium members and actually, this kind of lock can be very problematic to our running business if it will last any longer. It seems that the only solution is for you to run a 'git gc'.

Can someone please help? Also, could anyone tell us how to unlock this issue by ourselves, in the future maybe? Thanks a lot!

1 comment

Hello @sergio_sorgente ,

Welcome to the Community.

I just ran aggressive GC for the repository in question, it is not well below the read-only limit.


Hi Daniil,

I have read your answer in the ticket. I would ask something else there.


Thanks fort he support.

Best, Matteo.

Like Daniil Penkin likes this

Hi @Daniil Penkin 

please could you help us running the GC again?


Thanks, Matteo.

Done, and replied in the support ticket.



Log in or Sign up to comment

Atlassian Community Events