It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why doesn't git recognize master branch? Edited

I have the following simple Bitbucket (cloud) pipeline, where in this case the 

BITBUCKET_PR_DESTINATION_BRANCH = master
image: java:8
pipelines:
  pull-requests:
    'feature/*':
    - step:
        script:
        - git fetch "+refs/heads/*:refs/remotes/origin/*"
- git diff $BITBUCKET_PR_DESTINATION_BRANCH ./gradle.properties > diff.txt

When it executes, I get

+ git diff $BITBUCKET_PR_DESTINATION_BRANCH ./gradle.properties > diff.txt
fatal: ambiguous argument 'master': unknown revision or path not in the working tree

Why so? 

1 answer

1 accepted

0 votes
Answer accepted

I tried this, and it worked.

git fetch origin $BITBUCKET_PR_DESTINATION_BRANCH:$BITBUCKET_PR_DESTINATION_BRANCH

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

What We Learned When We Researched Open Source Vulnerabilities in 7 Popular Coding Languages

...hey are a part of us, shaping how we interact with the world around us. The same holds true for programming languages when we think about how different kinds of vulnerabilities raise their heads in t...

1,041 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you