Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Where do caches show up?

So I have a cache that I created in pipeline1 made to setup the cache which I then use in pipeline2. This cache called "bin" is cached from the root directory in pipeline1.

The output of pipeline2 reads: 

 

pipeline output help.PNG

Next, in one step, I ran a "ls -la" cmd in the root, but the bin folder did not show up. That step has the line "cache: - bin", so I know it is included.

 

Is there a reason it is not showing up?

And when trying to access this cache, does it need something other than "cd"?

1 answer

1 accepted

1 vote
Answer accepted

@Joshua von Damm cache feature is embedded, but it works automatically, so it is supposed , that you should not cd to it or ls manually.

Anyway, caches are lying in the appropariate directory where appropriate app, like docker, would create a cache. Look at the doc, table in the section Pre-defined caches

https://support.atlassian.com/bitbucket-cloud/docs/cache-dependencies/

Regards, Galyna

Thanks for the reply! I should have specified that I am using a custom cache, and based on the same article you linked, it should by default be in the root dir.

But I came across a fix that I don't think should have worked.

The fix: 

 

cache fix.PNG

For whatever reason, adding the $BITBUCKET_CLONE_DIR variable which specifies the root dir fixed the issue. This means that they could be lying about custom caches, and that it doesn't really start at the root dir unless you specifically tell it to. 

Like Galyna Zholtkevych likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

2,201 views 46 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you