It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SOLVED Pipeline Build Node JS fails with "permission denied, mkdir '/root/.npm'" Edited

Doing a pipeline build with Node (image: node:10.15.3). First script command is to install a global dependency. That fails when installing one of the sub dependencies and I'm dead in the water. Apparently it cannot access root folder. I'm not a Linux pro, just enough to be dangerous, so I'm scratching my head at this noise. Any thoughts or suggestions?

> sharp@0.22.1 install /usr/local/lib/node_modules/gridsome/node_modules/sharp
> (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)

ERR! sharp EACCES: permission denied, mkdir '/root/.npm'

 

1 answer

1 accepted

0 votes
Answer accepted

Solved. I was a dumbass and was installing the wrong thing.

Hey @Peter Kowalczyk I am having the same issue and I cannot figure out what I am doing wrong, can you elaborate a bit more and what you were installing and what you are installing now?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

What We Learned When We Researched Open Source Vulnerabilities in 7 Popular Coding Languages

...hey are a part of us, shaping how we interact with the world around us. The same holds true for programming languages when we think about how different kinds of vulnerabilities raise their heads in t...

1,052 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you