Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Previously Working .NET Core Pipeline Now Failing

5 Days ago, this .NET CORE web app build pipeline worked:

pipeline-good.JPG

 

As of today, a minor update to the branch, with no significant project, nuget, version updates now continuously fails:

pipeline-bad.JPG

The only difference I can detect is on the Build Engine version listed between the two builds -- the failing one is 16.2.xxxxx, whereas the one that worked was 16.0.xxx .

Did something change on the BitBucket end? We have likewise NOT made any YAML changes between these builds/commits.

Perplexed -- can anyone assist?

 

1 answer

1 accepted

1 vote
Answer accepted

Had same problem today.

I found following solution:

  • Remove "microsoft/dotnet:sdk" image.
  • Add specified image version (e.g. 3.0) under step
    • image: mcr.microsoft.com/dotnet/core/sdk:3.0 

I started seeing this today too. Someone definitely changed something.

Using this to Target 2.2 resolved build errors for me.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

Bitbucket Pipelines Runners is now in open beta

We are excited to announce the open beta program for self-hosted runners. Bitbucket Pipelines Runners is available to everyone. Please try it and let us know your feedback. If you have any issue...

3,877 views 68 21
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you