It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Account Variables are not recognized in pipeline step Edited

Hello there!

 

I have set up pipelines using repository and deployment variables...

...as well a uniquely named account variable (so it is not overwritten by repo vars)

 

but when, for example, showing all the variables via 'export' when running such step, the account variable does not show up

 

Bildschirmfoto 2019-06-12 um 13.40.57.pngBildschirmfoto 2019-06-12 um 13.41.57.png

 

Is there something I am missing or doing wrong here?

2 answers

1 vote

Hello,

Is the account where the Account Variable is defined, also the owner of the repository you're running Pipelines for?

Thanks,

Phil

Hello Philip!

 

The account is the owner of the repo as well as the user is part of the 'admin' group.

 

BB

Like gmathio likes this

I just tried and it seems to be working. Can you see if that's also an issue with any newly created account variables?

If it's still an issue, can I get you to open a support ticket for us to look into more detail.

Hi Philip!

 

I am sorry, but I just tried and nothing seems to have changed: new variables as well as the already present ones do not appear when `export` or alike. "Team" account variables are working ^^

 

Another thing I just noticed, when trying to set account variables with (some of) our other users: only two out of nine users (all 'admin' in BitBucket) are even seeing the menu entry "account variables". Is there something special to setup I didn't notice?

Hi Philip!

 

Thanks a lot for your effort, I have to subserviently apologize :D

 

I took the wrong assumption that my personal account variables are also available within the team's repositories' pipelines of the team I am a member of, and not just within my personal account repositories only.

 

Maybe, the docs can be just half a step more precise, haha :D

Variables specified for a team or an individual account can be accessed from all repositories that belong to the team or account.

 

 

Cheers
BB

No worries. Glad you got it working! I'll pass the feedback on to the documentation writers.

Like Björn Bartels likes this

@Philip Hodder i ran into the same problem today as i wanted to use personal AWS keys for the pipelines. I think this might be a super feature if i can set my own AWS credentials in my account settings and even if the owner of the repo is a group my own credential env vars are used. So i can see in AWS who has executed which pipeline on AWS :-) But if i set credentials env vars on the group level the account env vars are overwritten.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket Pipelines

What We Learned When We Researched Open Source Vulnerabilities in 7 Popular Coding Languages

...hey are a part of us, shaping how we interact with the world around us. The same holds true for programming languages when we think about how different kinds of vulnerabilities raise their heads in t...

1,031 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you