Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,815
Community Members
 
Community Events
165
Community Groups

No option to select Windows on new runner.

Edited

Windows-runner option.PNG
As you can see from the above photo, my repository has no option to select windows as a runner? Any ideas?

3 answers

1 accepted

0 votes
Answer accepted
lliang2 Atlassian Team Dec 07, 2021

Hey @Luke Irvine @Miklos Lorinczi 

Because window runner is still in EAP at the moment, we only enabled it for workspaces you fill in in the survey. If you try it with a new workspace other what you fill in in the survey, then you won't be able to see the windows option when you create runner.

Can you please send me the workspace url via email(lliang2@atlassian.com), I will enable them accordingly.

Cheers

Leo Liang

dear @lliang2

My issue was caused by dual accounts: my colleague requested the EAP to another Atlassian account, but after he contacted support and clarified the issue, the EAP was enabled on bitbucket.org/radiuzdev, and now I'm able to add self-hosted windows runners.

 Best Regards

Resolved my issue thanks @lliang2 

Try using a different browser.

I am having the same issue when using MS Edge but switched to Chrome and the issue is resolved. I would prefer to use Edge but will be using Chrome to create runners. Everything else appears to be operation in Edge.

I believe it has to do with my strict browser setting implemented on Edge. If I turn on Allow Cookies and Thirdparty Cookies here it seems to fix the issue: https://bitbucket.org:443

Hope this helps.

I'm facing the same issue. Can it be set up on already existing repos, or do i need to create a new one?

Screenshot 2021-12-07 at 12.20.37.png

No, existing repository is fine, but it must be in a workspace that Atlassian has authorized to the EAP. I only requested one workspace to be part of EAP, and only those repos have the option enabled.

Thanks for your answer, I'm pretty certain I requested the repository I'm trying to create the runner for. Maybe I misspelled the repo. @Miklos Lorinczi I'm guessing you specified the repository too?

I am pretty sure they did it on a workspace basis, so I would have to be the workspace name you requested on the signup. Maybe that was off.

Also, go to the workspace settings and try adding a runner there.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you