java.IO.IOException after upgrade to latest Version of Bamboo / Artifactory Plugin

Hi there,

We currently experience an error in our build job on Bamboo. Everything worked before. We have upgraded to the following versions:

  • Bamboo 5.10.3
  • Artifactory 4.7.0
  • Bamboo Artifactory Plugin 1.10.1

The error we experience is as follows:

12-Apr-2016 09:51:32 java.io.IOException: Failed to deploy file: HTTP response code: 404. HTTP response message: Not Found
12-Apr-2016 09:51:32 at org.jfrog.build.extractor.clientConfiguration.client.ArtifactoryBuildInfoClient.throwHttpIOException(ArtifactoryBuildInfoClient.java:743)
12-Apr-2016 09:51:32 at org.jfrog.build.extractor.clientConfiguration.client.ArtifactoryBuildInfoClient.uploadFile(ArtifactoryBuildInfoClient.java:623)
12-Apr-2016 09:51:32 at org.jfrog.build.extractor.clientConfiguration.client.ArtifactoryBuildInfoClient.deployArtifact(ArtifactoryBuildInfoClient.java:329)
12-Apr-2016 09:51:32 at org.jfrog.bamboo.task.ArtifactoryGenericDeployTask.deploy(ArtifactoryGenericDeployTask.java:200)
12-Apr-2016 09:51:32 at org.jfrog.bamboo.task.ArtifactoryGenericDeployTask.execute(ArtifactoryGenericDeployTask.java:111)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.task.TaskExecutorImpl.lambda$executeTasks$124(TaskExecutorImpl.java:269)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.task.TaskExecutorImpl.executeTaskWithPrePostActions(TaskExecutorImpl.java:202)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.task.TaskExecutorImpl.executeTasks(TaskExecutorImpl.java:269)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.task.TaskExecutorImpl.execute(TaskExecutorImpl.java:112)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.build.pipeline.tasks.ExecuteBuildTask.call(ExecuteBuildTask.java:74)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.v2.build.agent.DefaultBuildAgent.build(DefaultBuildAgent.java:215)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.v2.build.agent.BuildAgentControllerImpl$1.call(BuildAgentControllerImpl.java:139)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.v2.build.agent.BuildAgentControllerImpl$1.call(BuildAgentControllerImpl.java:130)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.variable.CustomVariableContextImpl.withVariableSubstitutor(CustomVariableContextImpl.java:215)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.v2.build.agent.BuildAgentControllerImpl.waitAndPerformBuild(BuildAgentControllerImpl.java:129)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.v2.build.agent.DefaultBuildAgent$1.run(DefaultBuildAgent.java:137)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.utils.BambooRunnables$1.run(BambooRunnables.java:49)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.security.ImpersonationHelper.runWith(ImpersonationHelper.java:31)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.security.ImpersonationHelper.runWithSystemAuthority(ImpersonationHelper.java:20)
12-Apr-2016 09:51:32 at com.atlassian.bamboo.security.ImpersonationHelper$1.run(ImpersonationHelper.java:52)
12-Apr-2016 09:51:32 at java.lang.Thread.run(Unknown Source)

 

Is there something we should change?

 

Thank you for any hint on this.

 

André

 

 

  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  
  

4 answers

Hi André,  

At first sight it seems that Artifactory returns 404 on the deployment,
try check Artifactory's request log for more info.

Best regards,
Dima
 

Hi Dima,

I have found the following line in the log of Artifactory (some sections are "blackened out"):

20160401152508|21|REQUEST|172.17.1.57|<username here>|PUT|/irma-snapshot-local/Ispin.Irma.Core/Debug/Ispin.Irma.Core-DEBUG-SNAPSHOT-134.zip;vcs.revision=be4bfc1b19b7cfc1902fcf232530bf998ce92fc7;build.timestamp=1459516931812;build.name=Irma%20Core%20-%20Development%20-%20Default%20Job;build.number=134;vcs.url=<git repository url here>|HTTP/1.1|404|0

I have checked our Bamboo build slave. The build artifact is created correctly on the build slave itself. According to this log entry, the upload to our Artifactory server using HTTP PUT fails.

Name resolution works fine. When I enter

http://<artifactory hostname here>/artifactory/irma-snapshot-local/

to browse the repository using IE or Firefox, I can see contents.

Any ideas?

Thank you.

André

Are you sure this 404 was produced by the same build run? (the date of the request log from Artifactory is 2016/04/01:15-25-08) 
Try to see if there any other 404 (more recent).
After you find a 404, check if you have another deploy of the same file which succeeded. if you do, the deploy was done correctly, so continue searching for other 404. This is result of optimization the plugin is doing (every artifact bigger than some size is being first deployed by "checksum deploy" which much faster and if not found - got 404, it being deployed the regular way).
Same time, while checking your logs please let me know what is your Bamboo server OS system and the Bamboo Agent OS system. I'll try to reproduce this on my machine.

Hi Dima,

Sorry for the log timestamp confusion.

I have again checked the logs. Here is an example which demonstrates the behaviour you mentioned. At that time, things worked well (as you can see). This was also the last time such a log entry was posted in the log (404 followed by a 201). 

20160401152509|7|REQUEST|172.17.1.57|<username>|PUT|/irma-snapshot-local/Ispin.Irma.Core/Release/Ispin.Irma.Core-RELEASE-SNAPSHOT-134.zip;vcs.revision=be4bfc1b19b7cfc1902fcf232530bf998ce92fc7;build.timestamp=1459516931812;build.name=Irma%20Core%20-%20Development%20-%20Default%20Job;build.number=134;vcs.url=<git repository url>|HTTP/1.1|404|0
20160401152509|18|REQUEST|172.17.1.57|<username>|PUT|/irma-snapshot-local/Ispin.Irma.Core/Release/Ispin.Irma.Core-RELEASE-SNAPSHOT-134.zip;vcs.revision=be4bfc1b19b7cfc1902fcf232530bf998ce92fc7;build.timestamp=1459516931812;build.name=Irma%20Core%20-%20Development%20-%20Default%20Job;build.number=134;vcs.url=<git repository url>|HTTP/1.1|201|165355

 On 2016-04-08 we upgraded Bamboo, Artifactory and the Bamboo Artifactory plugin to the versions mentioned in my previous post. Since then, we have the situation that an IOException is thrown in Bamboo (see stacktrace in my previous post). Since then, I also cannot see any PUT requests in the log, which indicate deployment activity.

Our Bamboo server is running on Debian 8 Jessie and we use Version 5.10.3 of Bamboo. Our Bamboo agent is a Windows 7 Professional 64-Bit

 

Thank you for your help.

André

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,584 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you