git clone hangs in Bamboo using Stash

I'm trying to setup a build plan using Stash as repository. I recently upgraded to the latest versions of Stash and Bamboo to enable the new version of application linking and I have linked the applications together and the links seems to work fine except that the build hangs indefinitely on "Checking out revision.

git clone works fine on the bamboo server over https as well ssh using my own username and ssh key.

I cannot see any errors in the logs and there is no firewall between the bamboo and stash servers. I have decreased the command timeout in the shared repository settings to 4 minutes but the build hangs much longer than that.

Product versions:

Stash v2.12.2

Bamboo v5.5.0 build 4304

Build log:

12-May-2014 13:42:55 Build My App - My App Build Plan - Default Job #3 (CATABI-BIBP-JOB1-3) started building on agent Default Agent
12-May-2014 13:42:55 Build working directory is /cmdata/bamboohome/xml-data/build-dir/CATABI-BIBP-JOB1
12-May-2014 13:42:55 Executing build My App - My App Build Plan - Default Job #3 (CATABI-BIBP-JOB1-3)
12-May-2014 13:42:55 Starting task 'Checkout Default Repository' of type 'com.atlassian.bamboo.plugins.vcs:task.vcs.checkout'
12-May-2014 13:42:55 Updating source code to revision: d7cde9db9a6f6b31f1c78052633b2530e81f057c
12-May-2014 13:42:56 Fetching 'refs/heads/master' from 'ssh://git@vcs.tjanstelogik.se:7999/catabi/myapp.git'.
12-May-2014 13:42:56 Git: Updating references
12-May-2014 13:42:56 Git:
12-May-2014 13:42:56 Checking out revision d7cde9db9a6f6b31f1c78052633b2530e81f057c.

5 answers

1 accepted

Hi Anders,

Do you have a native git capability configured? If you dont define one, Bamboo uses the bundled jgit which is quite buggy. Try to add a git capability and try again

0 votes
Timothy Chin Community Champion May 11, 2014

What Java version are you using for Bamboo?

Hi,

I'm using OpenJDK 1.7. java -version output:

java version "1.7.0_25"
OpenJDK Runtime Environment (IcedTea 2.3.10) (7u25-2.3.10-1~deb7u1)
OpenJDK Server VM (build 23.7-b01, mixed mode)

I was using the jgit client, which definitively shouldn't be used (and perhaps not even bundled with the product). Working like a charm with native git!

I have the same issue, and I have git capabilities set.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

240 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you