Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

bamboo can't connect to bitbucket cloud with Atlassian login

Config:

  • Bamboo server hosted on AWS ec2
  • Source Repository on bitbucket cloud under a team account.

Scenario:

  • Trying to use basic auth from Bamboo to bitbucket so build statuses show up on bitbucket.
  • Forced to use Atlassian login (which has to be an email).

Issue:

  • Authentication fails when trying to link a repository using basic auth credentials of bitbucket (xyz@email.com/password). I can login to bitbucket with the same credentials without any issues.
  • erro: "Failed to load data from Bitbucket. [403 Forbidden]"

What could be the issue here? Is new email based Atlassian login not supported? I also tried to use bitbucket user name - didn't work.

1 answer

0 votes

See https://confluence.atlassian.com/bamboo/bitbucket-cloud-289277000.html?utm_source=dac&utm_medium=blog&utm_campaign=totw, as documented there you must use an app password if using 2 factor authentication.

Alternatively you can switch to SSH private key authentication, it's also explained in the documentation linked.

Hope that helps

Thanks Piotr. I was not using 2 factor authentication. After seeing something suspicious in the logs today, I enabled SSL on the bamboo server with a CA cert and I was able to authenticate and load the repository.

However, I still can't get bamboo build statuses to show up in bitbucket. 

In some other article I  had read that for build statuses to show up I need to use basic auth which is what I am doing now. Still no luck.

I wonder if I need to do something else - from the documentation it looked like bamboo-bitbucket integration should work out of the box as long as 

1. I'm using basic auth.

2. Repository type is bitbucket cloud (and not git).

 

I'm doing both.

Update:

I just redid my bamboo installation from scratch and now the build status shows up on bitbucket. Using basic auth and bitbucket repo type.

Not very scientific way of soling an issue but I'll still take it. Thanks for your help.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

221 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you