artifact defined are never picked up

Hi,

I have defined my artifacts like below

Name: nfhWars

Location: target

Copy Pattern: **/*.war

The WAR files are placed in below folders

NFH-NFH4-JOB1\nettforhandler-dist\target\nettforhandler-dist-4.0.14-SNAPSHOT-wlsdomain-test\nettforhandler\nettforhandlerapp\abc.war

NFH-NFH4-JOB1\nettforhandler-dist\target\nettforhandler-dist-4.0.14-SNAPSHOT-wlsdomain-test\nettforhandler\nettforhandlerapp\def.war

both war files are folders and not archived files. Both contain directories and files.

I tried many times but the artifacts are never shown up and it says "No files found"

Any help or hint will be very helpful.

8 answers

1 accepted

0 votes
Accepted answer

It was not working because bamboo expects zipped or archived files as artifacts and not folders.

What applications are you working with here?

It is Maven based application in which I need to share my artifacts between different stages. The wars of one build in required in the later stages which is bundled together in final build. I tried various options but always end up with "No files found". At last I have used my remote server to copy the wars of previous build and then mix all the stuff there for final build. Not happy with this solution though. Artifact sharing is there for these stuff only. I will be more than happy to see this working so that I can recommend Bamboo for other projects in my company. Hope somebody from Atlassian can help here. Hoping to get some solution here.

Hey Sujeet,

I see that in your Copy Pattern you are using a forward slash, but your directory paths use back-slashes. Can you please try to use a back-slash in your Copy Pattern (**\*.war) and let me know if that makes any difference?

Cheers,
Armen

Change your Location to be nettforhandler-dist\target

Bamboo says "This entry cannot contain the character \"

In the location, I tried the below values and all of them have failed

target

nettforhandler-dist\target

\nettforhandler-dist\target\nettforhandler-dist-4.0.14-SNAPSHOT-wlsdomain-brumm\nettforhandler\nettforhandlerapp

${build.working.directory}/nettforhandler-dist/target

The copy pattern for them respectively are given below

**/*.war

**/*.war

*.war

**/*.war

Not sure where I am going wrong here.

Sujeet,

You are right - Bamboo doesn't allow the back-slash; I am sorry for the confusion. Please try to use: nettforhandler-dist/target for the Location, and **/*.war for the Copy Pattern. I just tested that on my local Bamboo instance. In case you still face the same problem, please raise a support ticket and provide your Bamboo logs with a screenshot of your Artifact configuration page.

Cheers,
Armen

Hi Armen,

As provided in my last update, Location "nettforhandler-dist/target" and Copy Pattern "**/*.war" is not working. I am using Bamboo 4.3.3 in windows XP. I have raised the ticket and the number is BSP-8963

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Thursday in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

1,751 views 8 7
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you