Wrong redirect after logging in with Bamboo behind mod_proxy

When running Bamboo behind apache proxy, and visiting /, we get redirected to:

/userlogin!default.action?os_destination=%252Fstart.action

so that after login, we get redirected to:

/%2Fstart.action

which generates a 404.

of course /start.action works. 

 

 

2 answers

1 accepted

0 votes
Accepted answer

The actual problem was missing redirectPort element on 8085 connector definition in server.xml.

Hi @Maxfield B,
if you are using a rewrites in you apache configuration, please add the NE Flag to you rewrite rule.

https://confluence.atlassian.com/display/BAMKB/404+page+as+a+result+of+double-encoded+slashes+in+the+URL+when+using+Apache

Greetings,
Oliver 

 

Thanks for taking the time to answer smile The problem was different than what you suggest, but one of the comments on that page helped me solve the problem.

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 17 hours ago in Jira

How you can achieve compact and easy-to-maintain workflows in your JIRA( Server)

This approach requires you to have the JIRA administrative rights. The main aim of this article is to help you achieve an organized, easy-to-maintain workflows in your JIRA instance thereby, reducin...

158 views 0 0
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you