Wrong redirect after logging in with Bamboo behind mod_proxy

When running Bamboo behind apache proxy, and visiting /, we get redirected to:

/userlogin!default.action?os_destination=%252Fstart.action

so that after login, we get redirected to:

/%2Fstart.action

which generates a 404.

of course /start.action works. 

 

 

2 answers

1 accepted

The actual problem was missing redirectPort element on 8085 connector definition in server.xml.

Hi @Maxfield B,
if you are using a rewrites in you apache configuration, please add the NE Flag to you rewrite rule.

https://confluence.atlassian.com/display/BAMKB/404+page+as+a+result+of+double-encoded+slashes+in+the+URL+when+using+Apache

Greetings,
Oliver 

 

Thanks for taking the time to answer smile The problem was different than what you suggest, but one of the comments on that page helped me solve the problem.

 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,584 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you