Why do my remote agents always report that the broker URI is invalid?

No matter what I change my values for the broker URI, it does not seem to work.  I tried using the IP address and the host name, and those didn't work.  I tried the broker uri and the broker client uri, to no avail.  Here is the error I continue to get:

INFO | jvm 1 | 2015/01/13 15:50:38 | 2015-01-13 15:50:38,887 WARN [Thread-0] [BambooActiveMQConnectionFactory] Broker URI: tcp://rd-bamboo-s.proddev.XXX:54663?wireFormat.maxInactivityDuration=300000 is invalid: java.net.ConnectException: Connection refused: connect

 I've tried telneting from the agent to port 54663 on rd-bamboo-s and I get data back, so it's not a firewall issue.  If there's any more information I can provide, please let me know.

4 answers

0 votes

Hello Rod,

Thank you for your question.

I would kindly ask you to refer to Troubleshooting Remote Agents documentation for further information.

If you find this answer useful, I would kindly ask you to accept it so the same will be visible to others who might be facing the same issue you have inquired.

Thank you for your understanding.

Kind regards,
Rafael P. Sperafico
Atlassian Support

0 votes

Are you getting this during startup only? Because if later, the agent works and you're not using 5.7, you can ignore that warning, it's a false positive.


Thanks Rafael, but unfortunately I've already been to that page and it doesn't seem to have helped me as much as I had hoped.  I've put the defaults back:

Broker URL: tcp://

Broker client URL: failover:(tcp://localhost:54663?wireFormat.maxInactivityDuration=300000)?initialReconnectDelay=15000&maxReconnectAttempts=10

And still no luck.  I'm able to telnet from the agent machine to the server on ports 8085 and 54663 with no issue at all.  However, I can't telnet from the server OR the agent machine on the agent's port 54663, which I expect I should be able to do when the agent is running...?  All of the firewalls are off on the agent and the server.

The server is Ubuntu 14.04 and the agent is Windows Server 2008 R2.  

netstat -an | findstr 54663 (on the Windows agent) shows nothing, even with the agent running.

netstat -an | grep 54663 (on the Ubuntu server) shows:

tcp6 0 0 :::54663 :::* LISTEN

I must admit, I haven't yet enabled DEBUG logging.  I'll do that now.

Przemyslaw, I do get this on startup of the agent, but eventually the client times out with a (long) Java exception:

javax.jms.JMSException: Connection refused: connect

Caused by: java.net.ConnectException: Connection refused: connect

Interestingly, even though the server says "There are currently no online remote agents configured on this Bamboo instance", I do see log entries immediately underneath saying "A remote agent is loading on RD-BAMBOO-C.proddev.XXX"


Figured it out...  This warning is the tip off:

 WARN [Thread-0] [BambooActiveMQConnectionFactory] Broker URI: tcp://localhost:54663?wireFormat.maxInactivityDuration=300000 is invalid: java.net.SocketTimeoutException: connect timed out

"localhost" doesn't make sense here.  Changing Broker client URI to:


fixed the problem.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

239 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you