Why are manual builds queued for several minutes?

I have a bamboo dev server. It runs build locally. 

Currently I am the only one using it and I'm doing manual builds, one at a time.

SOmetime manual build will kick-off after a few seconds but sometime they sit in the queue for a few minutes.

Why are they queued up for minutes? Nothing else is going on.

2 answers

This widget could not be displayed.
Marcin Oles Atlassian Team Nov 18, 2014

Hi Paul,

which version of Bamboo are you using? Always try to upgrade to the newest, there might have been some bugs fixed related to the build queue.

Optionally, when you expect a build to start immediately, you can go to Build → Build activity and monitor the build queue to verify that nothing is actually being executed at that time.

Regards,
Marcin Oleś 

This widget could not be displayed.

This might be this bug: https://jira.atlassian.com/browse/BAM-15187 It is fixed in upcoming 5.7.1 version

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

169 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you