When will node 4.x and 5.x be supported?

Node 4.x has been out for a few months now, since 2015-09-08 and 5.x since 2015-12-04.  When will the bamboo plugins support them and when will it be available for bamboo cloud?

2 answers

0 votes
Marcin Oles Atlassian Team Dec 16, 2015

Hello @Justin Hamade,

regarding Bamboo Node.js Plugin, there aren't any restrictions on Node.js version. If there is a capability for Node.js 5 or 4 available on build agent, then the plugin will be able to use them. So the plugin should already support Node 4 & 5 without any problems.

Regarding support for Node 4 & 5 on Bamboo Cloud, I think Node.js 4.1 is already available. I'm not sure when Node 5 will be added.

For bamboo cloud how does one go about adding a node version.  I only have 0.10 and 0.12 available, and the documentation says there should be an add executable link but I don't see that.

Screen Shot 2015-12-16 at 9.31.48 AM.png

Suggest an answer

Log in or Sign up to answer
Community showcase
Published yesterday in Opsgenie

Getting the Most out of Atlassian and Opsgenie Together

We’re excited to invite you to this action-packed webinar where we will demonstrate how to integrate Opsgenie’s powerful alerting and on-call management tools with your entire Atlassian stack. Mar...

33 views 0 0
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you