UnhandledWebdriverError empty message!

Hi everyone,

I m facing a problem and after hours looking for an answer on the web, I ve decided to ask you about it!

During my build, firefox is launched by Selenium, Right? I found out that the elastic instance that has been built uses firefox 23.0.1 and Selenium 2.35.0.

When I run my plan, the error I get in my log is

15-May-2014 16:06:19 1) TesteGoogle::testSave
15-May-2014 16:06:19 UnhandledWebDriverError:
15-May-2014 16:06:19
15-May-2014 16:06:19 /mnt/bamboo-ebs/bamboo-agent/build-dir/SYS-CI-JOB1/Library/php-webdriver-master/lib/WebDriverExceptions.php:61
15-May-2014 16:06:19 /mnt/bamboo-ebs/bamboo-agent/build-dir/SYS-CI-JOB1/Library/php-webdriver-master/lib/remote/HttpCommandExecutor.php:246
15-May-2014 16:06:19 /mnt/bamboo-ebs/bamboo-agent/build-dir/SYS-CI-JOB1/Library/php-webdriver-master/lib/remote/HttpCommandExecutor.php:147
15-May-2014 16:06:19 /mnt/bamboo-ebs/bamboo-agent/build-dir/SYS-CI-JOB1/Library/php-webdriver-master/lib/remote/RemoteWebDriver.php:33
15-May-2014 16:06:19 /mnt/bamboo-ebs/bamboo-agent/build-dir/SYS-CI-JOB1/Test/TesteGoogle.php:17
15-May-2014 16:06:19
15-May-2014 16:06:19 FAILURES!
15-May-2014 16:06:19 Tests: 1, Assertions: 0, Errors: 1.


Can you give me some tips... to debug and find this error!!!!!

Thank you in advance,

Luciana

By the way... on that file, line 17... that s what I ve got:

$this->driver = new RemoteWebDriver($host, $capabilities);

Wich has been built with:

// the endpoint of the Selenium Standalone Server

$host = 'http://localhost:4444/wd/hub'; // this is the default

// edit the capability, choose firefox as the browser

$capabilities = array(WebDriverCapabilityType::BROWSER_NAME => 'firefox');

Works fine in my machine.. but my selenium version is newer and so my firefox version!

1 answer

I don t know if anyoneelse is facing this problem.. but I had to compile firefox, saved an AMI with this compilation... and had to add a script to intialize selenium and firefox and I had to intialize it using:yum install alsa-lib-devel -y and Xvfb :1 -screen 0 1280x768x24 &
export DISPLAY=:1.

Now it s working!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published 3 hours ago in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

44 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you