Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,254,223
Community Members
 
Community Events
164
Community Groups

Unable to publish artifact (no error)

Hi,

I am trying to create a simple artifact to share a source tree between stages. This is just a simple test to help me better understand how Bamboo works.

I have Location set to "fw_comp" which is the Checkout Directory I have configured for the Source Code Checkout task. The Copy Pattern is **/* so I expect the full fw_comp tree to be copied into the artifact.

When I run I get the following error in the log. From what I have read, the error "Unable to publish artifact" is usually followed by some kind of reason but mine is just blank. Any idea what this means? This is a fresh install of Bamboo and we are all new to this tool so I am wondering if this indicates some kind of configuration problem rather than a problem with my plan config.

Thanks,

Phil

20-May-2014 14:46:20

Finished task 'Check out fw_comp from head of mainline R12.X branch (master as set in Project repositories)'

20-May-2014 14:46:20

Running pre-build action: VCS Version Collector

20-May-2014 14:46:20

Running pre-build action: Clover Grails PreBuild Action

20-May-2014 14:46:21

Running post build plugin 'Artifact Copier'

20-May-2014 14:46:21

Publishing an artifact: Firmware Repository

20-May-2014 14:46:46

Unable to publish artifact [Firmware Repository]:

20-May-2014 14:46:46

The artifact is required for down stream Stages and Jobs, build will now fail.

6 answers

I have to say, Bamboo looks very nice when it's working - but I am appalled at this and other failures. This has been an issue since 2014 and I have a similar problem today.

I am setting Location to . and Copy pattern to * and I get the following in the logs after a successful build:

 

Unable to publish artifact [name]: 

 

That's it. No explanation. 400GB+ free space as Frederik suggested could be a problem. @Matt Allen3 I would think my permissions are correct for the "." directory relative to the build working directory. I tried **, **/*, **/**, **/*.*. I also tried known directory names instead of .

I have a solution: https://jenkins.io/

These kind of useless error messages make working in bamboo very frustrating.  Tailing build agent's log files to troubleshoot build errors is decidedly un-cool.

I found that artifact publication can fail without an error if there is not enough disk space on the server (if using local storage). You can check the "Disk space free" on the "System information" page in your Bamboo configuration.

I added an improvement request to fix this:

https://jira.atlassian.com/browse/BAM-18854

In my case the solution, when finally found, was this:

I had used Artifact copy pattern "maven_*.jar". For some reason, the build was generating  the .jar file without the prefix maven. So by changing copy pattern to "*.jar", the artifact was found and passed ok into downstream

 

I have experienced this same problem recently. For me, the solution was to check the file and folder permissions of the artifact folder on the bamboo server, and make sure that the user running the bamboo server had ownership.

No, sorry, I never did.

@Philip Rittenhouse - Did you ever find a solution to this?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center on Kubernetes

Hi, If you are running self-managed environments and looking to adopt modern infrastructure, Bamboo Data Center can now be deployed in a Kubernetes cluster. By leveraging Kubernetes, you can easily...

660 views 3 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you