There were no files to upload.

Bamboo Server 6.2.2  (centos6)

Hi I have a problem with the deployment, it says 

There were no files to upload.

But when I  try to access the current working directory the artifact is saved there.

installer.bootstrapper\bin\Debug\sample-data-1.3.0.exe

I'm using the copy pattern:

**/sample-data-*.exe 

It was being built on our remote agent that is running on windows server  

Artifact handler is Amazon S3 with a file name

installer.bootstrapper\bin\Debug\sample-data-1.3.0.exe

Also  is it possible that the filename will be saved as 

sample-data-1.3.0.exe

and not

installer.bootstrapper\bin\Debug\sample-data-1.3.0.exe

 

Any thoughts will be much appreciated. Thanks

1 answer

Hi Adrian,

Have you tried other artifact definition syntax examples other than **/sample-data-*.exe as described here?

The copy pattern is relative to the location specified within the build directory and you may not use the absolute path to refer to the location.

Hi Jeyanthan, 

 

Thank you for your response, Yes, I've already tried other copy pattern.

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,066 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot