It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

There were no files to upload.

Bamboo Server 6.2.2  (centos6)

Hi I have a problem with the deployment, it says 

There were no files to upload.

But when I  try to access the current working directory the artifact is saved there.

installer.bootstrapper\bin\Debug\sample-data-1.3.0.exe

I'm using the copy pattern:

**/sample-data-*.exe 

It was being built on our remote agent that is running on windows server  

Artifact handler is Amazon S3 with a file name

installer.bootstrapper\bin\Debug\sample-data-1.3.0.exe

Also  is it possible that the filename will be saved as 

sample-data-1.3.0.exe

and not

installer.bootstrapper\bin\Debug\sample-data-1.3.0.exe

 

Any thoughts will be much appreciated. Thanks

1 answer

Hi Adrian,

Have you tried other artifact definition syntax examples other than **/sample-data-*.exe as described here?

The copy pattern is relative to the location specified within the build directory and you may not use the absolute path to refer to the location.

Hi Jeyanthan, 

 

Thank you for your response, Yes, I've already tried other copy pattern.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bamboo

Unable to add or edit Bitbucket Cloud repository in Bamboo

On 31 May, a GDPR-related change went live in the Bitbucket Cloud API that resulted in users not being able to create or edit Bitbucket Cloud Linked repositories in Bamboo. This API update removed t...

302 views 2 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you