The Bamboo "Branch Automatic Clean-up" feature doesn't appear to be working.

The Bamboo Branch Automatic Clean-up feature doesn't appear to be working. We have the Automatic Branch Clean-Up option enabled and set to remove branches after 7 days. The branches do NOT have the Do not clean up this Plan Branch automatically option checked. We're using Bamboo version 4.0.1 build 2907 which is linked to a GIT repository.

Let me know if you need any further information. Any help you can provide would be greatly appreciated... Thanks!

2 answers

1 accepted

0 votes
Accepted answer

This is fixed in Bamboo 4.1.1 (See https://jira.atlassian.com/browse/BAM-10737).

Hi Guac,

There are a lot of improvements and bug fixes related to branches in the latest Bamboo versions. Would that be an option for you to upgrade to the latest amBboo version (4.3.2)? You can install it in a test environment and check if the same problem persists. The feature is improved in the latest version to "<label id="label_chain_branch_enabled" for="chain_branch_enabled">Automatically manage branches</label>" as per the documentation.

Cheers,
Armen

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

229 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you