Task configuration for Pre-Post Build Command Runner not displaying

I downloaded the JAR and installed it in the WEB-INF/lib directory. After the restart, it shows on the Admin screen as working, but when I go to a plan to add some pre-post tasks, there is no interface for this function.

Any ideas? Running Bamboo 5.3 and have the latest JAR of this project.

1 answer

This widget could not be displayed.

Any reason you did not install via UPM? There are some hooks that Bamboo needs to read from the plugins atlassian-plugin.xml file, which I thought required more then just being present on the classpath (adding to web-inf/lib)

Also when you say admin screen is working, do you mean the add-on listing page? Does it show all modules enabled? ( i.e. "3 of 3 modules enabled")

I attempted to install via UPM, but said the plugin does not support this. Per instructions of the plugin, I had to manually deploy it. All modules are enabled and working, what I was talking about when referring to the missing admin page was the actual UI for using this plug-in in the MISC tab of a project plan.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

52 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you