Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,391
Community Members
 
Community Events
176
Community Groups

Starting Bamboo as a service in Centos 7

Hi, 

I tried following the instructions at:

https://confluence.atlassian.com/bamboo/running-bamboo-as-a-linux-service-416056046.html

 

But the script on that page requires an argument (start, restart, stop), but this is not specified anywhere in the procedure.

And my installation is not starting upon boot, but I can manually start with that script.

I've checked the catalina.out file, but it doesn't even get that far - 

How can I troubleshoot this?  

How do you enter the "start" argument with the start of the system?

 

 

3 answers

1 accepted

2 votes
Answer accepted

But the script on that page requires an argument (start, restart, stop), but this is not specified anywhere in the procedure.

It's not necessary to reference these explicitly anywhere. They're standard commands issued by the underlying OS service manager once the service has been registered.

Rather than troubleshooting the systemv service, for CentOS 7 I'd recommend setting it up as a systemd service using these instructions instead:

It's the standard on modern distros and more robust. I'll get the above instructions linked in the official doc too.

Hope this helps :)

Hey Jeremy - 

Perfect!  It all works, and things make a lot more sense to me now.  

Thanks for your help.

Best,

Jason

Also would suggest noting that in the first link I tried.  And add "centos7" in the description of the correct link.

Jeremy Owen Atlassian Team Feb 28, 2018

You're welcome! :) 

I'll absolutely add CentOS 7 into the description too.

0 votes

Hi Jason,

 

It sounds like Bamboo isn't starting when you reboot the system. Did you run sudo /sbin/chkconfig --add bamboo, which configures Bamboo to start on system startup?

Cheers,

Christian

Premier Support Engineer

Atlassian

Hi Christian, yes.  But as I mentioned - it makes sense that it will fail, as the script requires an argument, and none is provided upon reboot, as far as i can see.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events