Sending notifications on script task failure

I have a script task that will not send notifications on failure even though it detects the failure.

I've created a very simple plan to test this, with one task that echos a line and then "exit 1". The echo line does show in the logs. The build is detected as a failure, but the email notifications for event "Notify On All Build Errors" are never sent. The email notification for event "All Builds Completed" works fine.

All other notifications, Hipchat and email, seem to work fine, only failure on a script task does not work.

I'm not sure what to try from here, any advice?

1 answer

1 accepted

This widget could not be displayed.

Looks like a bug, please contact support at support.atlassian.com

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 11 hours ago in Statuspage

What are your best incident management tips and stories? #HugOps

 👋Community members! Downtime happens. And great incident response takes a village. Teams like Support, Dev, SRE, Ops, IT, and Marketing have to come together to resolve the problem while keep...

32 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you