Sending notifications on script task failure

I have a script task that will not send notifications on failure even though it detects the failure.

I've created a very simple plan to test this, with one task that echos a line and then "exit 1". The echo line does show in the logs. The build is detected as a failure, but the email notifications for event "Notify On All Build Errors" are never sent. The email notification for event "All Builds Completed" works fine.

All other notifications, Hipchat and email, seem to work fine, only failure on a script task does not work.

I'm not sure what to try from here, any advice?

1 answer

1 accepted

0 votes
Accepted answer

Looks like a bug, please contact support at support.atlassian.com

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

187 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you