Requirements are not being met by shared capabilities

We have remote agents hosted in AWS, and only in AWS. I have added the custom shared remote capability with the key "AgentLocation" and value "AWS".

I then created a build plan, and added the requirement "AgentLocation equals AWS". With this requirement enabled, I get the error message "No agents meet this job's requirements".

However, when I click the details of the requirement, the details page correctly reports that "All remote agents" support this requirement.

Have I missed a step somewhere? How is it that "No agents meet this job's requirements" when "All remote agents" support this requirement?

I am using Atlassian Bamboo version 5.9.0 build 5914 - 03 Jun 15

2 answers

This widget could not be displayed.

I just noticed https://jira.atlassian.com/browse/BAM-15274, which seems to have a similar issue.

This widget could not be displayed.

Another possibility is if you used the "dedicate agent" feature. Dedicated agents do not count.

That's both directions, if you have this job using dedicated agents, then it won't use any others.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

79 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you