Publishing artifacts not working

I've been struggling to get artifact publishing working, so I've configured the most simple test case that I can come up with and still getting no results.

The plan has a single job in it, with the following script:

if [ ! -d "artifacts" ] ; then
  mkdir artifacts
fi
echo "This is a test" > artifacts/test1.txt
echo "This is a different test" > test2.txt

The artifact definition for this job is the following:

Name: Retrieve test file

Location:

Copy pattern: *.txt

(I've also tried location = 'artifacts', I've tried copy pattern = '*', '**/*.txt', 'test2.txt', 'artifacts/test1.txt' and other variations)

I've verified, via SSH, that both files are created and are both readable by all users.

In each case, the result has been the log message 'Unable to publish artifact'.

Am I doing something wrong or is this a bug in Bamboo?

 

1 answer

1 accepted

0 votes
Accepted answer

Hello @Davo Smith,

I just tried your scenario on Bamboo 5.9.9 and it works as expected. If you leave Location empty and copy pattern is *.txt then Bamboo publishes only text2.txt file.

You can find your artifacts at Artifacts tab of Build resultartifacts_retrieve.png

If you have issues with Bamboo, please create request at support.atlassian.com and our Support Engineers will be glad to help you

 

Hi Alexey - thanks for getting back to me.

As it happens, I opened a support ticket a couple of days after I posted here ( https://support.atlassian.com/servicedesk/customer/portal/23/JST-179283 ) and it turned out to be a file permissions bug in the instance, which one of the support engineers was able to fix for me.

I'll mark your answer as correct as contacting support was the right answer.

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Thursday in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

1,436 views 7 7
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you