Problem with Bamboo Agent on 64-bit Windows 7

I have installed Bamboo 3.4.4 64-bit windows version on 64-bit Windows 7 machine. I tried installing the agent as a service.

When I point the wrapper.java.command property in the wrapp.er.conf file to a Java 7 64-bit JRE and start the agent the log shows:

INFO | jvm 5 | 2012/02/26 13:40:46 | java.net.SocketException: Permission denied: connect

2 answers

1 accepted

I believe I figured this out. I was using Java 7U3 from home to connect via VPN to Bamboo at work. I did some research and found this thread : http://www.java.net/node/703177 that discussed issues with JDK 7 using VPNs. Though the thread talks about CISCO VPN clients, I have the Juniper Network Connect version 6.5. I installed the 64-bit JDK 6 Update 31 and pointed the "wrapper.java.command" at the new java.exe, without changing anything else and it worked fine. I will try with JDK 7 tomorrow at work and confirm if it works.

See previous answer.

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot