Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Post JDK 'jdk1.8.0_73' Install on Bamboo Remote Agent Server the Agent crashes

Hello 

 

 We need JDK 8 for build executions and i installed JDK 'jdk1.8.0_73' on the Remote Agent server. Post installation the application never comes up and we get a message saying A remote agent is loading like below

Feb 19, 2016 2:03:07 AM A remote agent is loading on <Server-Name> (10.1.54.23).

 

 However when i uninstall JAVA 8 the application comes back to life and everything works fine.

 

 We are on Bamboo 5.3 , please help me to troubleshoot this issue.

 

Cheers


Sandeep

1 answer

1 accepted

1 vote
Answer accepted

You need to use JDK 1.6 to run agent and then add JDK 1.8 as agent capability. Please check that agent starts using JDK 1.6, not 1.8

Thanks Alexey ,

 Can you please let me know how to start the Bamboo Agent with JDK 1.6 instead of 1.8 , As soon as i install JDK 1.8 the RA might be picking up JDK 1.8 to start instead of 1.6.

 

 Do i have to perform 'Disabling auto-capability detection for the remote agent' so that it will not use JDK 1.8 ? 

 

https://confluence.atlassian.com/bamboo/additional-remote-agent-options-436044733.html 

 

Cheers


Sandeep

how do you start your RA?

The RA is installed on Windows 2008 box and i have installed it as Windows Service. The services automatically starts during server reboot or we can manually start from services box. 

look at your JAVA_HOME path variable, it should point to JDK 1.6 

Still i am getting the same error. The home is set to JDK 1.6 .., 

C:\Users\s736228>echo %java_home%
D:\ProgramFiles\Java\jdk1.6.0_95

C:\Users\s736228>java -version
java version "1.8.0_73"
Java(TM) SE Runtime Environment (build 1.8.0_73-b02)
Java HotSpot(TM) 64-Bit Server VM (build 25.73-b02, mixed mode)

C:\Users\s736228>

Now i set the path to JDK 1.6 and restarted the services. However the problem still exists.

 

C:\Users\s736228>java -version
java version "1.8.0_73"
Java(TM) SE Runtime Environment (build 1.8.0_73-b02)
Java HotSpot(TM) 64-Bit Server VM (build 25.73-b02, mixed mode)

C:\Users\s736228>echo %java_home%
D:\ProgramFiles\Java\jdk1.6.0_95

C:\Users\s736228>set PATH=D:\ProgramFiles\Java\jdk1.6.0_95\bin;%PATH%

C:\Users\s736228>java -version
java version "1.6.0_95"
Java(TM) SE Runtime Environment (build 1.6.0_95-b12)
Java HotSpot(TM) 64-Bit Server VM (build 20.95-b02, mixed mode)

Hi,

in your RA's configuration, conf\wrapper.conf file, you could try and set 'wrapper.java.command' to explicitly use your JRE 1.6 java.exe

Thanks Alexey and Frederic 

 

 I entered '%java_home%\bin' in the PATH of Environment Variable and things got fixed. Looks like from command prompt if we set the PATH it will not save permanently. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

986 views 4 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you