My Elastic Agent is permenantly stuck on "pending"

My Elastic Agent is permenantly stuck on "pending", the elastic instance has started correctly and I can ssh in and do things, but the agent will not start.

Any assistance with this would be great

3 answers

This widget could not be displayed.

UPDATE: I can start an agent manually by ssh'ing in to the elastic instance, but no matter what I do I can't get the instance to start by itself

This widget could not be displayed.

Hello Samuel,

Can you provide agent logs from /home/bamboo/bamboo-elastic-agent.out?

There were no logs in that directory, from what I could tell the agent wasn't even trying to / being told to start At the moment as a temporary work around I made a init.d script to start an agent when the instance is created. This is a hacky work around I hope their is a nicer solution :D

What ami do you use? Is it stock image or custom one?

This widget could not be displayed.

Hello, Even my Windows Stock image is stuck on pending, Can somebody please help me with that

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

172 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you