Moving the folder for a Bamboo remote agent

Of the 10 remote agents we have, three used a different base path - which was annoying.  So I stopped them, moved them, updated both bamboo-agent.cfg.xml and wrapper.conf and restarted.

2 of the three are functioning correctly.  But one always attempts to create a deploy job's "Build working directory" using the old path.  How can I correct this?

2 answers

Figured this one out.  The server on which the Agent resided had been moved from an internal datacentre to AWS.  The team that moved it had failed to stop the original server instance (even though the name no longer resolved to it) and its copy of the Bamboo agent was still running.

Once this was resolved, I revoked the access for the old server instance (again), and accepted the new one, restarted everything and then it started working correctly.

Hi David! How are you doing?

When you restarted, did you check whether the processes were killed in the operating system? Maybe the one that is not correct yet failed to stop and is still using an old process.

Hope this helps!

Thanks,

Cristiano

We rebooted the whole server - but no help.  So it can't be that.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Monday in Jira Ops

Jira Ops Early Access Program Update #1: Announcing our next feature and a new integration

Thanks for signing up for Jira Ops! I’m Matt Ryall, leader for the Jira Ops product team at Atlassian. Since this is a brand new product, we’ll be delivering improvements quickly and sharing updates...

499 views 0 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you