Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Migrating to AMPS 8.1.2 got banned dependency. Is there a way to resolve this, from dependency tree

accelQ March 8, 2024

Banned Deps:

Found Banned Dependency: org.slf4j:slf4j-api:jar:1.7.36
Found Banned Dependency: org.apache.httpcomponents:httpclient:jar:4.5.13
Found Banned Dependency: org.apache.httpcomponents:httpcore:jar:4.4.13


dependency Tree:

com.aq:aqconnect:atlassian-plugin:1.0.8
[INFO] +- com.atlassian.bamboo:atlassian-bamboo-web:jar:6.8.0:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-core:jar:6.8.0:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-api:jar:6.8.0:provided
[INFO] | | | +- com.atlassian.bamboo:atlassian-bamboo-api-agent-bootstrap:jar:6.8.0:provided
[INFO] | | | +- com.atlassian.extras:atlassian-extras-api:jar:3.3.0:provided
[INFO] | | | +- com.atlassian.config:atlassian-config:jar:1.0.1:provided
[INFO] | | | +- com.atlassian.plugins:atlassian-plugins-webfragment-api:jar:4.0.0:provided
[INFO] | | | +- com.atlassian.bandana:atlassian-bandana:jar:3.1:provided
[INFO] | | | +- com.atlassian.cache:atlassian-cache-api:jar:2.11.3:provided
[INFO] | | | | +- com.atlassian.bundles:jsr305:jar:1.1:provided
[INFO] | | | | \- com.atlassian.instrumentation:atlassian-instrumentation-core:jar:2.2.1:provided
[INFO] | | | +- org.apache.ant:ant:jar:1.8.4:provided
[INFO] | | | | \- org.apache.ant:ant-launcher:jar:1.8.4:provided
[INFO] | | | +- org.apache.commons:commons-text:jar:1.1:provided
[INFO] | | | +- commons-configuration:commons-configuration:jar:1.4-atlassian-1:provided
[INFO] | | | | \- commons-jxpath:commons-jxpath:jar:1.2:provided
[INFO] | | | +- commons-beanutils:commons-beanutils:jar:1.9.3:provided
[INFO] | | | +- com.atlassian.seraph:atlassian-seraph:jar:4.0.2:provided
[INFO] | | | +- opensymphony:osuser:jar:1.0-20060106:provided
[INFO] | | | +- org.acegisecurity:acegi-security:jar:1.0.4:provided
[INFO] | | | | \- oro:oro:jar:2.0.8:provided
[INFO] | | | +- net.jcip:jcip-annotations:jar:1.0:provided
[INFO] | | | +- com.atlassian.soy:soy-template-renderer-plugin-api:jar:4.0.4:provided
[INFO] | | | | \- com.atlassian.soy:soy-template-renderer-api:jar:4.0.4:provided
[INFO] | | | \- org.fusesource.jansi:jansi:jar:1.11:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-deployments-api:jar:6.8.0:provided
[INFO] | | +- com.atlassian.bamboo:bamboo-specs:jar:6.8.0:provided
[INFO] | | | \- com.google.code.findbugs:jsr305:jar:3.0.0:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-core-agent-bootstrap:jar:6.8.0:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-utils:jar:6.8.0:provided
[INFO] | | | \- org.jsoup:jsoup:jar:1.10.2:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-xml-utils:jar:6.8.0:provided
[INFO] | | +- com.atlassian.analytics:analytics-api:jar:5.6.1:provided
[INFO] | | +- com.atlassian.bamboo.security.classlist:security-classlist-api:jar:1.0.1:provided
[INFO] | | +- com.atlassian.bonnie:atlassian-bonnie:jar:6.1-lucene4.6-1:provided
[INFO] | | | +- org.apache.lucene:lucene-analyzers-common:jar:4.6.0:provided
[INFO] | | | \- com.ibm.icu:icu4j:jar:3.8:provided
[INFO] | | +- com.atlassian.cache:atlassian-cache-ehcache:jar:2.11.3:provided
[INFO] | | | \- com.atlassian.cache:atlassian-cache-common-impl:jar:2.11.3:provided
[INFO] | | +- com.atlassian.collectors:atlassian-collectors-util:jar:0.10:provided
[INFO] | | +- com.atlassian.ip:atlassian-ip:jar:3.1:provided
[INFO] | | +- com.atlassian.plugins:atlassian-plugins-core:jar:4.1.0:provided
[INFO] | | | \- com.atlassian.plugins:atlassian-plugins-api:jar:4.1.0:provided
[INFO] | | +- com.atlassian.plugins:atlassian-plugins-spring:jar:4.1.0:provided
[INFO] | | | \- org.springframework:spring-web:jar:4.1.7.RELEASE:provided
[INFO] | | +- com.atlassian.plugins:atlassian-plugins-webfragment:jar:4.0.0:provided
[INFO] | | +- com.atlassian.security:atlassian-secure-random:jar:3.2.4:provided
[INFO] | | +- com.atlassian.security:atlassian-secure-xml:jar:3.2.4:provided
[INFO] | | +- com.atlassian.security.auth.trustedapps:atlassian-trusted-apps-seraph-integration:jar:4.1.0:provided
[INFO] | | +- com.atlassian.security.auth.trustedapps:atlassian-trusted-apps-core:jar:4.1.0:provided
[INFO] | | +- com.atlassian.spring:atlassian-spring:jar:2.0.7:provided
[INFO] | | | \- org.springframework:spring-jdbc:jar:2.0.6:provided
[INFO] | | | \- org.springframework:spring-dao:jar:2.0.6:provided
[INFO] | | +- com.atlassian.utils:atlassian-processutils:jar:1.7.9:provided
[INFO] | | | \- org.jvnet.winp:winp:jar:1.17-atlassian1:provided
[INFO] | | +- com.atlassian.velocity:atlassian-velocity:jar:0.5:provided
[INFO] | | +- com.sun.xml.bind:jaxb-core:jar:2.2.11:provided
[INFO] | | +- org.apache.commons:commons-collections4:jar:4.2:provided
[INFO] | | +- commons-lang:commons-lang:jar:2.6:provided
[INFO] | | +- commons-validator:commons-validator:jar:1.6:provided
[INFO] | | +- commons-httpclient:commons-httpclient:jar:3.1-atlassian-2:provided
[INFO] | | +- dom4j:dom4j:jar:1.6.1:provided
[INFO] | | +- jaxen:jaxen:jar:1.1.6:provided
[INFO] | | +- javacvs:javacvs:jar:atlassian-20080407:provided
[INFO] | | +- org.apache.commons:commons-lang3:jar:3.7:provided
[INFO] | | +- org.springframework:spring-jms:jar:5.0.8.RELEASE:provided
[INFO] | | | +- org.springframework:spring-messaging:jar:5.0.8.RELEASE:provided
[INFO] | | | \- org.springframework:spring-tx:jar:5.0.8.RELEASE:provided
[INFO] | | +- org.springframework:spring-context-support:jar:5.0.8.RELEASE:provided
[INFO] | | +- com.tek42.perforce:p4java:jar:0.7.5-atlassian-13:provided
[INFO] | | +- commons-digester:commons-digester:jar:2.1:provided
[INFO] | | +- org.aspectj:aspectjrt:jar:1.9.1:provided
[INFO] | | +- org.aspectj:aspectjweaver:jar:1.9.1:provided
[INFO] | | +- org.hibernate:hibernate-jpamodelgen:jar:5.3.4.Final:provided
[INFO] | | +- cglib:cglib-nodep:jar:2.2:provided
[INFO] | | +- com.sun.mail:javax.mail:jar:1.5.2:provided
[INFO] | | +- org.igniterealtime.smack:smack-core:jar:4.1.9:provided
[INFO] | | | +- xpp3:xpp3:jar:1.1.4c:provided
[INFO] | | | \- org.jxmpp:jxmpp-core:jar:0.4.2:provided
[INFO] | | | \- org.jxmpp:jxmpp-util-cache:jar:0.4.2:provided
[INFO] | | +- org.igniterealtime.smack:smack-tcp:jar:4.1.9:provided
[INFO] | | +- joda-time:joda-time:jar:2.8.2:provided
[INFO] | | +- log4j:log4j:jar:1.2.17:provided
[INFO] | | +- org.quartz-scheduler:quartz:jar:2.2.3:provided
[INFO] | | +- org.tmatesoft.svnkit:svnkit:jar:1.8.15:provided
[INFO] | | | +- de.regnis.q.sequence:sequence-library:jar:1.0.3:provided
[INFO] | | | +- org.tmatesoft.sqljet:sqljet:jar:1.1.10:provided
[INFO] | | | +- net.java.dev.jna:jna:jar:4.1.0:provided
[INFO] | | | +- net.java.dev.jna:jna-platform:jar:4.1.0:provided
[INFO] | | | +- com.trilead:trilead-ssh2:jar:1.0.0-build221:provided
[INFO] | | | +- com.jcraft:jsch.agentproxy.connector-factory:jar:0.0.7:provided
[INFO] | | | | +- com.jcraft:jsch.agentproxy.core:jar:0.0.7:provided
[INFO] | | | | +- com.jcraft:jsch.agentproxy.usocket-jna:jar:0.0.7:provided
[INFO] | | | | | \- net.java.dev.jna:platform:jar:3.4.0:provided
[INFO] | | | | +- com.jcraft:jsch.agentproxy.usocket-nc:jar:0.0.7:provided
[INFO] | | | | +- com.jcraft:jsch.agentproxy.sshagent:jar:0.0.7:provided
[INFO] | | | | \- com.jcraft:jsch.agentproxy.pageant:jar:0.0.7:provided
[INFO] | | | \- com.jcraft:jsch.agentproxy.svnkit-trilead-ssh2:jar:0.0.7:provided
[INFO] | | +- com.jcraft:jsch:jar:0.1.54:provided
[INFO] | | +- velocity:velocity:jar:1.4:provided
[INFO] | | +- com.thoughtworks.xstream:xstream:jar:1.4.10:provided
[INFO] | | | \- xmlpull:xmlpull:jar:1.1.3.1:provided
[INFO] | | +- com.thoughtworks.xstream:xstream-hibernate:jar:1.4.10:provided
[INFO] | | +- org.apache.lucene:lucene-core:jar:4.6.0:provided
[INFO] | | +- com.atlassian:lucene-filtered-collector:jar:4.6.1:provided
[INFO] | | +- com.atlassian.mail:atlassian-mail:jar:2.7.19:provided
[INFO] | | | +- javax.mail:javax.mail-api:jar:1.5.6:provided
[INFO] | | | \- com.atlassian:atlassian-localhost:jar:1.1.0:provided
[INFO] | | +- org.apache.activemq:activemq-broker:jar:5.14.5:provided
[INFO] | | | +- org.apache.activemq:activemq-client:jar:5.14.5:provided
[INFO] | | | | +- org.apache.geronimo.specs:geronimo-jms_1.1_spec:jar:1.1.1:provided
[INFO] | | | | \- org.fusesource.hawtbuf:hawtbuf:jar:1.11:provided
[INFO] | | | \- org.apache.activemq:activemq-openwire-legacy:jar:5.14.5:provided
[INFO] | | +- org.apache.xbean:xbean-spring:jar:3.2:provided
[INFO] | | +- org.apache.sshd:sshd-core:jar:1.7.0:provided
[INFO] | | +- com.atlassian.botocss:botocss:jar:3.0:provided
[INFO] | | | \- org.antlr:antlr-runtime:jar:3.4:provided
[INFO] | | | \- org.antlr:stringtemplate:jar:3.2.1:provided
[INFO] | | +- org.scala-lang:scala-library:jar:2.10.3:provided
[INFO] | | +- com.tdunning:t-digest:jar:3.2:provided
[INFO] | | +- com.atlassian.plugins:atlassian-plugins-webresource:jar:3.3.7:provided
[INFO] | | | +- com.atlassian.plugins:atlassian-plugins-webresource-api:jar:3.3.7:provided
[INFO] | | | \- com.atlassian.sourcemap:sourcemap:jar:1.7.2:provided
[INFO] | | +- com.atlassian.plugins:atlassian-plugins-webresource-common:jar:4.1.0:provided
[INFO] | | +- com.atlassian.fugue:fugue:jar:2.7.0:provided
[INFO] | | +- org.codehaus.jackson:jackson-mapper-asl:jar:1.9.1:provided
[INFO] | | | \- org.codehaus.jackson:jackson-core-asl:jar:1.9.1:provided
[INFO] | | +- com.atlassian.crowd:embedded-crowd-spi:jar:3.2.4:provided
[INFO] | | +- com.atlassian.crowd:embedded-crowd-api:jar:3.2.4:provided
[INFO] | | \- com.atlassian.crowd:embedded-crowd-core:jar:3.2.4:provided
[INFO] | | +- com.atlassian.crowd:crowd-events:jar:3.2.4:provided
[INFO] | | +- com.atlassian.crowd:crowd-ldap:jar:3.2.4:provided
[INFO] | | | +- com.atlassian.crowd:crowd-synchronisation:jar:3.2.4:provided
[INFO] | | | \- org.springframework.ldap:spring-ldap-core:jar:2.2.1.RELEASE:provided
[INFO] | | +- com.atlassian.crowd:crowd-azure-ad:jar:3.2.4:provided
[INFO] | | | +- com.nimbusds:nimbus-jose-jwt:jar:4.38:provided
[INFO] | | | +- com.nimbusds:lang-tag:jar:1.4.3:provided
[INFO] | | | +- net.minidev:json-smart:jar:1.3.1:provided
[INFO] | | | \- com.microsoft.azure:adal4j:jar:1.2.0:provided
[INFO] | | | \- com.nimbusds:oauth2-oidc-sdk:jar:5.18.1:provided
[INFO] | | +- com.atlassian.crowd:crowd-remote:jar:3.2.4:provided
[INFO] | | | \- com.atlassian.crowd:crowd-integration-client-rest:jar:3.2.4:provided
[INFO] | | | \- org.apache.httpcomponents:httpclient-cache:jar:4.5.3:provided
[INFO] | | \- com.atlassian.crowd:crowd-core-tiny:jar:3.2.4:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-persistence:jar:6.8.0:provided
[INFO] | | +- com.atlassian.user:atlassian-user-hibernate3:jar:5.4.14:provided
[INFO] | | | +- com.atlassian.security:atlassian-password-encoder:jar:3.0:provided
[INFO] | | | +- com.opensymphony.propertyset:core:jar:1.6.0-atlassian-8:provided
[INFO] | | | \- com.opensymphony.propertyset.providers:hibernate5:jar:1.6.0-atlassian-8:provided
[INFO] | | +- org.springframework:spring-orm:jar:5.0.8.RELEASE:provided
[INFO] | | \- com.atlassian.crowd:crowd-persistence-hibernate5:jar:3.2.4-hibernate53-1:provided
[INFO] | | +- com.atlassian.crowd:crowd-persistence:jar:3.2.4:provided
[INFO] | | +- com.google.code.findbugs:findbugs-annotations:jar:3.0.1:provided
[INFO] | | +- com.atlassian.hibernate:atlassian-hibernate5.2-extras:jar:6.1.1:provided
[INFO] | | \- com.atlassian.crowd:crowd-server-api:jar:3.2.4:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-migration:jar:6.8.0:provided
[INFO] | | +- com.atlassian.activeobjects:activeobjects-spi:jar:1.2.3:provided
[INFO] | | +- org.codehaus.woodstox:atlassian-wstx-core-asl:jar:4.1.2-atlassian-1:provided
[INFO] | | \- org.codehaus.staxmate:staxmate:jar:2.0.0:provided
[INFO] | | \- org.codehaus.woodstox:stax2-api:jar:3.0.4:provided (version selected from constraint [3.0.0,3.1.0))
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-language:jar:6.8.0:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-charts:jar:6.8.0:provided
[INFO] | | +- jfree:jfreechart:jar:1.0.9:provided
[INFO] | | \- jfree:jcommon:jar:1.0.12:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-upgrader:jar:6.8.0:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-license:jar:6.8.0:provided
[INFO] | | +- com.atlassian.extras:atlassian-extras-core:jar:3.3.0:provided
[INFO] | | | \- com.atlassian.extras:atlassian-extras-decoder-v2:jar:3.3.0:provided
[INFO] | | +- com.atlassian.extras:atlassian-extras-common:jar:3.3.0:provided
[INFO] | | +- com.atlassian.extras:atlassian-extras-legacy:jar:3.3.0:provided
[INFO] | | | \- com.atlassian.extras:atlassian-extras-decoder-api:jar:3.3.0:provided
[INFO] | | +- io.atlassian.fugue:fugue:jar:3.0.0:provided
[INFO] | | \- xpp3:xpp3_min:jar:1.1.4c:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-agent-classserver:jar:6.8.0:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-agent-remote:jar:6.8.0:provided
[INFO] | | | +- org.apache.activemq:activemq-pool:jar:5.14.5:provided
[INFO] | | | | \- org.apache.activemq:activemq-jms-pool:jar:5.14.5:provided
[INFO] | | | \- com.esotericsoftware:kryo:jar:3.0.3:provided
[INFO] | | | +- com.esotericsoftware:reflectasm:jar:1.10.1:provided
[INFO] | | | | \- org.ow2.asm:asm:jar:5.0.3:provided
[INFO] | | | +- com.esotericsoftware:minlog:jar:1.3.0:provided
[INFO] | | | \- org.objenesis:objenesis:jar:2.1:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-agent-bootstrap:jar:6.8.0:provided
[INFO] | | | \- org.slf4j:jcl-over-slf4j:jar:1.7.10:provided
[INFO] | | \- com.atlassian.bamboo:atlassian-bamboo-agent-elastic:jar:6.8.0:provided
[INFO] | | \- com.atlassian.aws:atlassian-aws-bootstrap:jar:1.0.170:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-agent-local:jar:6.8.0:provided
[INFO] | | \- com.atlassian.bamboo:atlassian-bamboo-agent-core:jar:6.8.0:provided
[INFO] | | +- com.atlassian.bamboo.plugins:atlassian-bamboo-plugin-ssh:jar:6.8.0:provided
[INFO] | | +- org.apache.activemq:activemq-ra:jar:5.14.5:provided
[INFO] | | | +- org.apache.activemq:activemq-kahadb-store:jar:5.14.5:provided
[INFO] | | | \- org.apache.geronimo.specs:geronimo-j2ee-connector_1.5_spec:jar:2.0.0:provided
[INFO] | | \- org.apache.geronimo.components:geronimo-transaction:jar:3.1:provided
[INFO] | | +- org.apache.geronimo.specs:geronimo-jta_1.1_spec:jar:1.1.1:provided
[INFO] | | \- org.apache.geronimo.specs:geronimo-j2ee-connector_1.6_spec:jar:1.0:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-agent-elastic-server:jar:6.8.0:provided
[INFO] | | +- com.atlassian.aws:atlassian-aws:jar:1.0.170:provided
[INFO] | | | +- com.amazonaws:aws-java-sdk-core:jar:1.11.394:provided
[INFO] | | | | \- software.amazon.ion:ion-java:jar:1.0.2:provided
[INFO] | | | +- com.amazonaws:aws-java-sdk-ec2:jar:1.11.394:provided
[INFO] | | | | \- com.amazonaws:jmespath-java:jar:1.11.394:provided
[INFO] | | | +- com.amazonaws:aws-java-sdk-s3:jar:1.11.394:provided
[INFO] | | | | \- com.amazonaws:aws-java-sdk-kms:jar:1.11.394:provided
[INFO] | | | +- com.amazonaws:aws-java-sdk-codedeploy:jar:1.11.394:provided
[INFO] | | | +- com.amazonaws:aws-java-sdk-iam:jar:1.11.394:provided
[INFO] | | | +- org.bouncycastle:bcpkix-jdk15on:jar:1.59:provided
[INFO] | | | +- com.fasterxml.jackson.core:jackson-databind:jar:2.8.10:provided
[INFO] | | | | +- com.fasterxml.jackson.core:jackson-annotations:jar:2.8.0:provided
[INFO] | | | | \- com.fasterxml.jackson.core:jackson-core:jar:2.8.10:provided
[INFO] | | | \- com.fasterxml.jackson.dataformat:jackson-dataformat-cbor:jar:2.8.10:provided
[INFO] | | +- com.atlassian.bamboo:atlassian-bamboo-agent-elastic-shared:jar:6.8.0:provided
[INFO] | | \- com.atlassian.tunnel:atlassian-tunnel:jar:1.8.8:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-maven-embedder:jar:6.8.0:provided
[INFO] | | +- org.jetbrains:annotations:jar:13.0:provided
[INFO] | | +- org.apache.maven:maven-core:jar:3.0.5:provided
[INFO] | | | +- org.apache.maven:maven-settings-builder:jar:3.0.5:provided
[INFO] | | | +- org.apache.maven:maven-repository-metadata:jar:3.0.5:provided
[INFO] | | | +- org.apache.maven:maven-artifact:jar:3.0.5:provided
[INFO] | | | +- org.apache.maven:maven-aether-provider:jar:3.0.5:provided
[INFO] | | | +- org.sonatype.aether:aether-impl:jar:1.13.1:provided
[INFO] | | | +- org.sonatype.aether:aether-api:jar:1.13.1:provided
[INFO] | | | +- org.sonatype.aether:aether-util:jar:1.13.1:provided
[INFO] | | | \- org.codehaus.plexus:plexus-interpolation:jar:1.14:provided
[INFO] | | +- com.google.inject:guice:jar:4.0:provided
[INFO] | | | \- aopalliance:aopalliance:jar:1.0:provided
[INFO] | | +- org.sonatype.aether:aether-connector-wagon:jar:1.13.1:provided
[INFO] | | | \- org.sonatype.aether:aether-spi:jar:1.13.1:provided
[INFO] | | +- org.apache.maven.wagon:wagon-provider-api:jar:2.4:provided
[INFO] | | +- org.apache.maven.wagon:wagon-file:jar:2.4:provided
[INFO] | | \- org.apache.maven.wagon:wagon-http:jar:2.4:provided
[INFO] | | \- org.apache.maven.wagon:wagon-http-shared4:jar:2.4:provided
[INFO] | +- com.atlassian.bamboo:atlassian-bamboo-import-export:jar:6.8.0:provided
[INFO] | | +- org.yaml:snakeyaml:jar:1.18:provided
[INFO] | | +- com.atlassian.bamboo:bamboo-specs-api:jar:6.8.0:provided
[INFO] | | \- com.spotify:docker-client:jar:shaded:8.11.7:provided
[INFO] | +- com.atlassian.bamboo:atlassian-embedded-crowd-atlassian-user:jar:6.8.0:provided
[INFO] | | +- com.atlassian.bucket:atlassian-bucket:jar:5.1.6:provided
[INFO] | | +- com.atlassian.crowd:crowd-integration-seraph:jar:3.2.4:provided
[INFO] | | | \- com.atlassian.crowd:crowd-integration-client-common:jar:3.2.4:provided
[INFO] | | +- com.atlassian.crowd:crowd-api:jar:3.2.4:provided
[INFO] | | +- com.atlassian.crowd:crowd-core:jar:3.2.4:provided
[INFO] | | | +- com.atlassian.crowd:crowd-password-encoders:jar:3.2.4:provided
[INFO] | | | | \- org.springframework.security:spring-security-core:jar:4.2.4.RELEASE:provided
[INFO] | | | \- com.atlassian.crowd:crowd-server-common:jar:3.2.4:provided
[INFO] | | +- com.atlassian.crowd:crowd-integration-api:jar:3.2.4:provided
[INFO] | | +- com.atlassian.user:atlassian-user-api:jar:5.4.14:provided
[INFO] | | | \- com.opensymphony.propertyset:api:jar:1.6.0-atlassian-8:provided
[INFO] | | \- com.atlassian.user:atlassian-user-core:jar:5.4.14:provided
[INFO] | +- com.atlassian:webwork-compat:jar:1.33:provided
[INFO] | | \- javax.servlet:javax.servlet-api:jar:3.0.1:provided
[INFO] | +- com.atlassian.applinks:applinks-api:jar:5.4.12:provided
[INFO] | | \- com.atlassian.annotations:atlassian-annotations:jar:0.16:provided
[INFO] | +- com.atlassian.applinks:applinks-host:jar:5.4.12:provided
[INFO] | +- com.atlassian.applinks:applinks-spi:jar:5.4.12:provided
[INFO] | +- com.atlassian.beehive:beehive-api:jar:0.2.1:provided
[INFO] | +- com.atlassian.beehive:beehive-single-node:jar:0.2.1:provided
[INFO] | | \- com.atlassian.beehive:beehive-core:jar:0.2.1:provided
[INFO] | +- com.atlassian.core:atlassian-core:jar:5.0.2:provided
[INFO] | | +- com.google.guava:guava:jar:10.0.1:provided
[INFO] | | +- commons-collections:commons-collections:jar:3.1:provided
[INFO] | | +- commons-logging:commons-logging:jar:1.0.4:compile
[INFO] | | +- opensymphony:oscore:jar:2.2.7:provided
[INFO] | | \- com.atlassian.image:atlassian-image-consumer:jar:1.0.1:provided
[INFO] | +- com.atlassian.html:atlassian-html-encoder:jar:1.5:provided
[INFO] | +- com.atlassian.http:atlassian-http:jar:2.0.2:provided
[INFO] | +- com.atlassian.json:atlassian-json-api:jar:0.9:provided
[INFO] | +- com.atlassian.johnson:atlassian-johnson-core:jar:3.5.0:provided
[INFO] | | \- com.atlassian.plugins:atlassian-plugins-servlet:jar:3.2.8:provided
[INFO] | +- com.atlassian.plugins:atlassian-plugins-schema:jar:4.1.0:provided
[INFO] | | \- com.atlassian.plugins:atlassian-plugins-osgi:jar:4.1.0:provided
[INFO] | | +- com.atlassian.plugins:atlassian-plugins-osgi-events:jar:4.1.0:provided
[INFO] | | +- biz.aQute.bnd:biz.aQute.bndlib:jar:2.4.1:provided
[INFO] | | +- org.apache.felix:org.apache.felix.framework:jar:4.2.1:provided
[INFO] | | \- org.twdata.pkgscanner:package-scanner:jar:0.9.5:provided
[INFO] | +- com.atlassian.profiling:atlassian-profiling:jar:1.9:provided
[INFO] | +- com.atlassian.sal:sal-api:jar:3.0.8:provided
[INFO] | +- com.atlassian.sal:sal-spi:jar:3.0.8:provided
[INFO] | +- com.atlassian.sal:sal-spring:jar:3.0.8:provided
[INFO] | +- com.atlassian.sal:sal-trust-api:jar:3.0.8:provided
[INFO] | +- com.atlassian.scheduler:atlassian-scheduler-api:jar:1.6.0:provided
[INFO] | +- com.atlassian.scheduler:atlassian-scheduler-core:jar:1.6.0:provided
[INFO] | +- com.atlassian.scheduler:atlassian-scheduler-quartz2:jar:1.6.0:provided
[INFO] | | \- org.quartz-scheduler:quartz-oracle:jar:2.1.7:provided
[INFO] | +- com.atlassian.security:atlassian-secure-utils:jar:3.2.4:provided
[INFO] | +- com.atlassian.tenancy:atlassian-tenancy-api:jar:2.0.0:provided
[INFO] | | +- com.atlassian.util.concurrent:atlassian-util-concurrent:jar:2.4.1:provided
[INFO] | | \- com.atlassian.event:atlassian-event:jar:2.3.2:provided
[INFO] | +- com.atlassian.xwork:atlassian-xwork-12:jar:2.5.10-struts-2:provided
[INFO] | | \- com.atlassian.xwork:atlassian-xwork-core:jar:2.5.10-struts-2:provided
[INFO] | +- io.atlassian.util.concurrent:atlassian-util-concurrent:jar:4.0.0:provided
[INFO] | +- com.h2database:h2:jar:1.4.194:provided
[INFO] | +- org.apache.activemq:activemq-http:jar:5.14.5-atlassian-1:provided
[INFO] | | +- org.apache.activemq:activemq-spring:jar:5.14.5:provided
[INFO] | | | \- org.apache.commons:commons-pool2:jar:2.4.2:provided
[INFO] | | +- org.apache.activemq:activemq-stomp:jar:5.14.5:provided
[INFO] | | +- org.apache.activemq:activemq-mqtt:jar:5.14.5:provided
[INFO] | | | +- org.apache.activemq.protobuf:activemq-protobuf:jar:1.1:provided
[INFO] | | | +- org.fusesource.mqtt-client:mqtt-client:jar:1.14:provided
[INFO] | | | +- org.fusesource.hawtdispatch:hawtdispatch-transport:jar:1.22:provided
[INFO] | | | | \- org.fusesource.hawtdispatch:hawtdispatch:jar:1.22:provided
[INFO] | | | +- org.apache.geronimo.specs:geronimo-j2ee-management_1.1_spec:jar:1.0.1:provided
[INFO] | | | \- commons-net:commons-net:jar:3.5:provided
[INFO] | | \- org.eclipse.jetty.aggregate:jetty-all:jar:9.2.13.v20150730:provided
[INFO] | +- org.hibernate:hibernate-core:jar:5.3.4.Final-atlassian-6:provided
[INFO] | | +- org.jboss.logging:jboss-logging:jar:3.3.2.Final:provided
[INFO] | | +- javax.persistence:javax.persistence-api:jar:2.2:provided
[INFO] | | +- org.javassist:javassist:jar:3.23.1-GA:provided
[INFO] | | +- net.bytebuddy:byte-buddy:jar:1.8.15:provided
[INFO] | | +- antlr:antlr:jar:2.7.7:provided
[INFO] | | +- org.jboss.spec.javax.transaction:jboss-transaction-api_1.2_spec:jar:1.1.1.Final:provided
[INFO] | | +- org.jboss:jandex:jar:2.0.5.Final:provided
[INFO] | | +- com.fasterxml:classmate:jar:1.3.4:provided
[INFO] | | +- javax.activation:javax.activation-api:jar:1.2.0:provided
[INFO] | | \- org.hibernate.common:hibernate-commons-annotations:jar:5.0.4.Final:provided
[INFO] | +- org.hibernate:hibernate-c3p0:jar:5.3.4.Final:provided
[INFO] | +- org.hibernate:hibernate-ehcache:jar:5.3.4.Final:provided
[INFO] | | \- net.sf.ehcache:ehcache:jar:2.10.3:provided
[INFO] | +- org.slf4j:jul-to-slf4j:jar:1.7.10:provided
[INFO] | +- org.slf4j:slf4j-log4j12:jar:1.7.10:provided
[INFO] | +- org.springframework:spring-beans:jar:5.0.8.RELEASE:provided
[INFO] | +- org.springframework:spring-context:jar:5.0.8.RELEASE:provided
[INFO] | | +- org.springframework:spring-aop:jar:5.0.8.RELEASE:provided
[INFO] | | \- org.springframework:spring-expression:jar:5.0.8.RELEASE:provided
[INFO] | +- org.springframework:spring-core:jar:5.0.8.RELEASE:provided
[INFO] | | \- org.springframework:spring-jcl:jar:5.0.8.RELEASE:provided
[INFO] | +- rome:rome:jar:1.0:provided
[INFO] | +- com.mchange:c3p0:jar:0.9.5.2:provided
[INFO] | | \- com.mchange:mchange-commons-java:jar:0.2.11:provided
[INFO] | +- de.schlichtherle.truezip:truezip-file:jar:7.7.10:provided
[INFO] | | +- de.schlichtherle.truezip:truezip-driver-file:jar:7.7.10:provided
[INFO] | | \- de.schlichtherle.truezip:truezip-kernel:jar:7.7.10:provided
[INFO] | +- de.schlichtherle.truezip:truezip-driver-zip:jar:7.7.10:provided
[INFO] | | +- de.schlichtherle.truezip:truezip-swing:jar:7.7.10:provided
[INFO] | | +- org.apache.commons:commons-compress:jar:1.9:provided
[INFO] | | \- org.bouncycastle:bcprov-jdk15on:jar:1.52:provided
[INFO] | +- jdom:jdom:jar:1.0:provided
[INFO] | +- javax.transaction:jta:jar:1.0.1B:provided
[INFO] | +- com.github.ziplet:ziplet:jar:2.1.2:provided
[INFO] | +- org.apache.struts:struts2-core:jar:2.5.17-atlassian-1:provided
[INFO] | | +- ognl:ognl:jar:3.1.15:provided
[INFO] | | \- org.apache.logging.log4j:log4j-api:jar:2.10.0:provided
[INFO] | +- org.freemarker:freemarker:jar:2.3.24-atlassian-20:provided
[INFO] | | +- logkit:logkit:jar:1.2:provided
[INFO] | | \- com.google.code.findbugs:annotations:jar:3.0.0:provided
[INFO] | +- opensymphony:sitemesh:jar:2.5-atlassian-6:provided
[INFO] | +- commons-fileupload:commons-fileupload:jar:1.3.3:provided
[INFO] | +- org.tuckey:urlrewritefilter:jar:4.0.3:provided
[INFO] | +- velocity-tools:velocity-tools:jar:1.2:provided
[INFO] | +- org.hamcrest:hamcrest-all:jar:1.3:provided
[INFO] | +- javax.xml.stream:stax-api:jar:1.0-2:provided
[INFO] | +- org.apache.maven:maven-embedder:jar:3.0.5:provided
[INFO] | | +- org.apache.maven:maven-settings:jar:3.0.5:provided
[INFO] | | +- org.apache.maven:maven-plugin-api:jar:3.0.5:provided
[INFO] | | +- org.apache.maven:maven-model-builder:jar:3.0.5:provided
[INFO] | | +- org.apache.maven:maven-compat:jar:3.0.5:provided
[INFO] | | +- org.codehaus.plexus:plexus-utils:jar:2.0.6:provided
[INFO] | | +- org.codehaus.plexus:plexus-classworlds:jar:2.4:provided
[INFO] | | +- org.sonatype.sisu:sisu-inject-plexus:jar:2.3.0:provided
[INFO] | | | \- org.sonatype.sisu:sisu-inject-bean:jar:2.3.0:provided
[INFO] | | +- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:provided
[INFO] | | +- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
[INFO] | | +- org.sonatype.plexus:plexus-cipher:jar:1.7:provided
[INFO] | | \- commons-cli:commons-cli:jar:1.2:provided
[INFO] | +- org.apache.maven:maven-model:jar:3.0.5:provided
[INFO] | +- com.octo.captcha:jcaptcha:jar:2.0-alpha-1:provided
[INFO] | +- com.octo.captcha:jcaptcha-api:jar:2.0-alpha-1:provided
[INFO] | +- com.jhlabs:filters:jar:2.0.235:provided
[INFO] | +- org.apache.struts:struts2-sitemesh-plugin:jar:2.1.8.1:provided
[INFO] | +- org.apache.logging.log4j:log4j-to-slf4j:jar:2.7:provided
[INFO] | +- org.apache.httpcomponents:httpmime:jar:4.5.5:provided
[INFO] | +- org.reflections:reflections:jar:0.9.10:provided
[INFO] | \- xerces:xercesImpl:jar:2.11.0:provided
[INFO] | \- xml-apis:xml-apis:jar:1.4.01:provided
[INFO] +- com.atlassian.plugin:atlassian-spring-scanner-annotation:jar:1.2.13:compile
[INFO] +- com.atlassian.plugin:atlassian-spring-scanner-runtime:jar:1.2.13:runtime
[INFO] +- javax.inject:javax.inject:jar:1:provided
[INFO] +- junit:junit:jar:4.10:test
[INFO] | \- org.hamcrest:hamcrest-core:jar:1.1:provided
[INFO] +- com.atlassian.plugins:atlassian-plugins-osgi-testrunner:jar:1.2.3:test
[INFO] | +- org.apache.wink:wink-client:jar:1.1.3-incubating:test
[INFO] | | +- org.apache.wink:wink-common:jar:1.1.3-incubating:test
[INFO] | | | \- org.apache.geronimo.specs:geronimo-annotation_1.1_spec:jar:1.0:test
[INFO] | | +- javax.xml.bind:jaxb-api:jar:2.2:test
[INFO] | | +- com.sun.xml.bind:jaxb-impl:jar:2.2.1.1:test
[INFO] | | \- javax.activation:activation:jar:1.1:test
[INFO] | +- commons-io:commons-io:jar:1.4:provided
[INFO] | +- com.google.code.gson:gson:jar:2.2.2-atlassian-1:provided
[INFO] | \- com.atlassian.upm:upm-api:jar:2.15:test
[INFO] +- javax.ws.rs:jsr311-api:jar:1.1.1:provided
[INFO] +- com.googlecode.json-simple:json-simple:jar:1.1.1:compile
[INFO] +- org.apache.httpcomponents.client5:httpclient5:jar:5.3.1:compile
[INFO] | +- org.apache.httpcomponents.core5:httpcore5:jar:5.2.4:compile
[INFO] | +- org.apache.httpcomponents.core5:httpcore5-h2:jar:5.2.4:compile
[INFO] | \- org.slf4j:slf4j-api:jar:1.7.36:compile
[INFO] +- org.apache.avalon.framework:avalon-framework-impl:jar:4.3.1:compile
[INFO] | \- org.apache.avalon.framework:avalon-framework-api:jar:4.3.1:compile
[INFO] \- core:aqCore:jar:1.0:compile
[INFO] +- commons-codec:commons-codec:jar:1.10:compile
[INFO] \- org.apache.httpcomponents:httpclient:jar:4.5.13:compile
[INFO] \- org.apache.httpcomponents:httpcore:jar:4.4.13:compile


POM file

<?xml version="1.0" encoding="UTF-8"?>


    <modelVersion>4.0.0</modelVersion>
    <groupId>com.aq</groupId>
    <artifactId>aqconnect</artifactId>
    <version>1.0.8</version>

    <organization>
        <name>ACCELQ</name>
        <url>http://www.accelq.com/</url>
    </organization>

    <name>aqconnect</name>
    <description>ACCELQ Continuous Integration</description>
    <packaging>atlassian-plugin</packaging>

    <properties>
        <bamboo.version>6.8.0</bamboo.version>
        <bamboo.data.version>6.8.0</bamboo.data.version>
        <amps.version>8.1.2</amps.version>
        <plugin.testrunner.version>1.2.3</plugin.testrunner.version>
        <atlassian.spring.scanner.version>1.2.13</atlassian.spring.scanner.version>
        <!-- This key is used to keep the consistency between the key in atlassian-plugin.xml and the key to generate bundle. -->
        <atlassian.plugin.key>${project.groupId}.${project.artifactId}</atlassian.plugin.key>
        <!-- <extn>jar</extn> -->
    </properties>

    <dependencies>
        <dependency>
            <groupId>com.atlassian.bamboo</groupId>
            <artifactId>atlassian-bamboo-web</artifactId>
            <version>${bamboo.version}</version>
            <scope>provided</scope>
        </dependency>

        <dependency>
            <groupId>com.atlassian.plugin</groupId>
            <artifactId>atlassian-spring-scanner-annotation</artifactId>
            <version>${atlassian.spring.scanner.version}</version>
            <scope>compile</scope>
        </dependency>

        <dependency>
            <groupId>com.atlassian.plugin</groupId>
            <artifactId>atlassian-spring-scanner-runtime</artifactId>
            <version>${atlassian.spring.scanner.version}</version>
            <scope>runtime</scope>
        </dependency>
        <dependency>
            <groupId>javax.inject</groupId>
            <artifactId>javax.inject</artifactId>
            <version>1</version>
            <scope>provided</scope>
        </dependency>
       
        <dependency>
            <groupId>junit</groupId>
            <artifactId>junit</artifactId>
            <version>4.10</version>
            <scope>test</scope>
        </dependency>

        <!-- WIRED TEST RUNNER DEPENDENCIES -->
        <dependency>
            <groupId>com.atlassian.plugins</groupId>
            <artifactId>atlassian-plugins-osgi-testrunner</artifactId>
            <version>${plugin.testrunner.version}</version>
            <scope>test</scope>
        </dependency>
        <dependency>
            <groupId>javax.ws.rs</groupId>
            <artifactId>jsr311-api</artifactId>
            <version>1.1.1</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>com.googlecode.json-simple</groupId>
            <artifactId>json-simple</artifactId>
            <version>1.1.1</version>
        </dependency>
        <dependency>
            <groupId>org.apache.httpcomponents.client5</groupId>
            <artifactId>httpclient5</artifactId>
            <version>5.3.1</version>
        </dependency>
        <dependency>
            <groupId>org.apache.avalon.framework</groupId>
            <artifactId>avalon-framework-impl</artifactId>
            <version>4.3.1</version>
        </dependency>
        <dependency>
            <groupId>core</groupId>
            <artifactId>aqCore</artifactId>
<!--            <scope>system</scope>-->
            <version>1.0</version>
<!--            <systemPath>${pom.baseUri}/src/lib/core-1.0-SNAPSHOT.jar</systemPath>-->
        </dependency>
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>com.atlassian.maven.plugins</groupId>
                <artifactId>bamboo-maven-plugin</artifactId>
                <version>${amps.version}</version>
                <extensions>true</extensions>
                <configuration>
                    <productVersion>${bamboo.version}</productVersion>
                    <productDataVersion>${bamboo.data.version}</productDataVersion>
                    <enableQuickReload>true</enableQuickReload>
                    <enableFastdev>false</enableFastdev>

                    <!-- See here for an explanation of default instructions: -->
                    <instructions>
                        <Atlassian-Plugin-Key>${atlassian.plugin.key}</Atlassian-Plugin-Key>

                        <!-- Add package to export here -->
                        <Export-Package>
                            com.example.api,
                        </Export-Package>

                        <!-- Add package import here -->
                        <Import-Package>
                            org.springframework.osgi.*;resolution:="optional",
                            org.eclipse.gemini.blueprint.*;resolution:="optional",
                            *
                        </Import-Package>

                        <!-- Ensure plugin is spring powered -->
                        <Spring-Context>*</Spring-Context>
                    </instructions>
                </configuration>
            </plugin>

            <plugin>
                <groupId>com.atlassian.plugin</groupId>
                <artifactId>atlassian-spring-scanner-maven-plugin</artifactId>
                <version>${atlassian.spring.scanner.version}</version>
                <executions>
                    <execution>
                        <goals>
                            <goal>atlassian-spring-scanner</goal>
                        </goals>
                        <phase>process-classes</phase>
                    </execution>
                </executions>
                <configuration>
                    <scannedDependencies>
                        <dependency>
                            <groupId>com.atlassian.plugin</groupId>
                            <artifactId>atlassian-spring-scanner-external-jar</artifactId>
                        </dependency>
                    </scannedDependencies>
                    <verbose>false</verbose>
                </configuration>
            </plugin>
        </plugins>
    </build>
    <repositories>
        <repository>
          <id>atlassian-public</id>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
            <checksumPolicy>warn</checksumPolicy>
          </snapshots>
          <releases>
            <enabled>true</enabled>
            <checksumPolicy>warn</checksumPolicy>
          </releases>
        </repository>
       <repository>
         <id>atlassian-plugin-sdk</id>
          <url>file://${env.ATLAS_HOME}/repository</url>
          <snapshots>
            <enabled>true</enabled>
          </snapshots>
          <releases>
            <enabled>true</enabled>
            <checksumPolicy>warn</checksumPolicy>
          </releases>
        </repository>
    </repositories>
    <pluginRepositories>
        <pluginRepository>
          <id>atlassian-public</id>
          <releases>
            <enabled>true</enabled>
            <checksumPolicy>warn</checksumPolicy>
          </releases>
          <snapshots>
            <updatePolicy>never</updatePolicy>
            <checksumPolicy>warn</checksumPolicy>
          </snapshots>
        </pluginRepository>
        <pluginRepository>
          <id>atlassian-plugin-sdk</id>
          <url>file://${env.ATLAS_HOME}/repository</url>
          <releases>
            <enabled>true</enabled>
            <checksumPolicy>warn</checksumPolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
          </snapshots>
        </pluginRepository>
    </pluginRepositories>
</project>

1 answer

0 votes
Shashank Kumar
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 10, 2024

Hello accelQ.

Welcome to Atlassian community.

I believe your answer is covered in this article > https://community.developer.atlassian.com/t/more-info-on-amps-banned-plugin-dependency/46036/4

Regards,

Shashank Kumar

**please don't forget to Accept the answer if your query was answered**

 

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events