Migrate Bamboo Deployment Requirement Task to Agent Assignment

We are migrating from Bamboo 5.9 to 5.14. On our current instance, wit have Requirements for Deployments plugin installed. This functionality comes out of box with 5.13+ with agent assignments. Has anyone figured out a clever way of how to migrate requirement tasks to the standard functionality? We have over 500 usages of deployment requirements in our system, and need an automated way to perform this migration. No support is provided by Atlassian. 

2 answers

0 votes

Why do you need to migrate? You can leave existing deployments unchanged and use new functionality only for new environments

Hi Alexey, while the plugin still works in our target version (5.14.3.1) it is marked as Incompatible. As the functionality is now in the core product, the plugin is likely to not even work anymore with future version. The migration is required for this reason.

You're right, created https://jira.atlassian.com/browse/BAM-18213 to track this work

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,078 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot