Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,652
Community Members
 
Community Events
176
Community Groups

JNDI email configuration NameNotFoundException

I am trying to setup email configuration for Bamboo, same operation worked for confluence. But it always pop out same error. 

 

Server.xml was modified ,and two email.jar was moved to required directory.

 

Official Guide

The mail settings you entered were not valid. Error thrown was: javax.naming.NameNotFoundException: Name [mail/SmtpServer] is not bound in this Context. Unable to find [mail].

1 answer

I solved it ~ hah~

 

it turns out i don't need to add whole piece into server.xml, only the content in Resource tag is enough.

 

<Context path="/bamboo" docBase="${catalina.base}/atlassian-bamboo" reloadable="true">
          <Resource name="mail/GmailSmtpServer"
            auth="Container"
            type="javax.mail.Session"
            mail.smtp.host="smtp.gmail.com"
            mail.smtp.port="465"
            mail.smtp.auth="true"
            mail.smtp.user="<your-name>@gmail.com"
            password="<your-pw>"
            mail.smtp.starttls.enable="true"
            mail.smtp.socketFactory.class="javax.net.ssl.SSLSocketFactory"
          />
</Context>

After putting the Resource stanza inside the existing Context tags, I also had to enable less secure app in gmail.

You can find out more here:  https://support.google.com/accounts/answer/6010255?hl=en

 

Hope this helps!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events