How to use Bamboo 5.14.x and NUnit 3?

Now that Bamboo 5.14 is out and supposedly supports NUnit 3 how do we configure this? The documentation seems to still be the older format.  I installed NUnit 3 console to my Windows server, setup the capability for NUnit Runner to point to the nunit3-console yet I'm still getting an error on the XML format output or something along that lines.  Has anyone gotten NUnit 3 to work yet and if so how do we configure this?

1 answer

1 accepted

1 votes

There's a bug that causes both NUnit 3 and 2 to show up as NUnit Runner in the capability section. You need to select the correct NUnit Runner, the one that comes later in the list should be NUnit 3. You can verify it by clicking the capability after you've defined it, the URL should contain the string 'system.builder.nunit3' (and not nunit).

Thank you. For anyone struggling with this you have to add a NEW executable to server capabilities and choose the second NUnit runner in the list AFTER installing the NUnit 3 console to your server so you have the path to the console executable.  

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,075 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot