How can I use Ant 1.8.2 with Bamboo onDemand?

I created a build plan using Ant to compile my project. It fails because my project requires Ant 1.8.2, but Bamboo onDemand, since it runs Bamboo 3.0, works with Ant 1.7.1. I tried to create a new builder for Ant 1.8.2, but I don't have permissions (and I'm the admin).

I've read that Bamboo onDemand will upgrade to Bamboo 3.4 soon (https://answers.atlassian.com/questions/36624/ondemand-bamboo-version-upgrade) and then my build plan will work, but is there any way it could work before that happen?

Thank you very much.

2 answers

1 accepted

1 vote
Accepted answer

It's possible.

You should install newer Ant on your instance using EBS. Once you start your instance from Bamboo, you'll be able to associate new Builders with your image (go to Elastic Bamboo/Instances, click on Image Config, click Edit, Add Capability combo is at the bottom of the page)

I tried but I wasn't able to configure properly a new instance with Ant 1.8.2, so I gave up.

Some weeks ago Bamboo onDemand was updated, and Ant 1.8.2 is now available, so I don't have this problem anymore.

Anyway, thank you very much for your help, Przemek.

And the next update will include 1.8.4 ;-)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

201 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you