Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,701
Community Members
 
Community Events
176
Community Groups

Fatal: unable to acess GIT SSl certificate problem: self signed

 When trying to setup Bamboo to connect to our GIT repo, I receive the following error

fatal: unable to access 'https://xxxxxx:8443/scm/xxxx/xxxx.git/': SSL certificate problem: self signed certificate

We do use a selfsigned cert, however in bitbucket I was able to fix that with the keytool and adding the cert to bitbucket. How can I fix this in bamboo? 

2 answers

I believe i have added the public into the CACerts using the portecle app.

Assuming Bamboo have no truststore configured it should use cacerts from JAVA to get the public certificates.

Not sure what you mean by GIT as a capability

Bamboo will use JGIT  (a Java embedded client of git) instead of GIT from your terminal. As a consequence the configuration to avoid the SSL Verification will not take effect.

This is our doc on how to configure it: Defining a new version control capability - Atlassian documentation.

No, didn't no i had to?

You don't need to do it, but it would be a good test to check if the problem is related to the GIT client used by Bamboo and the server environment variables loaded so far.

Yes

Good to know, that at least make sense if your configuration has already http.sslVerify option set to false.

I ran the following if thats what you mean.

Yes, that is what I was talking about.


Please share

  1. the full stack trace of the error reported here.
  2. is git capability configured?
  3. try to run a script task with the git command you need, so we can validate that this is achievable from Bamboo.
0 votes

Hello Nelson,

You will need to add the public certificate in Bamboo if you didn't do it yet and add the reference to cacerts in the git configuration.

The same problem is described here: Unable to clone Git repository due to self signed certificate - Atlassian Documentation. This document is for Fisheye, but the same procedure should fix Bamboo as well.

I did try using that app and exported the bitbucket pem then imported it into my cacerts but still have the same issue.

Some useful questions to more forward:

  • Just to make sure, have you added the public certificate or the private one? (you need the public in Bamboo)
  • Are you using GIT as a capability?
  • Are you calling git commands from a script task?
  • Is git working at the terminal, from outside Bamboo?
  • Have you tried the git configuration suggested in the link I shared above?

Responses in order. Just so you know, my issue is within bitbucket site and bamboo site when trying to link repositories.

I believe i have added the public into the CACerts using the portecle app.

Not sure what you mean by GIT as a capability

No, didnt no i had to?

Yes

I ran the following if thats what you mean.

git config --global http.sslVerify false
Like James Card likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events